httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grant Furick" <furi...@msn.com>
Subject mod_auth_digest and -DEAPI compile flag
Date Fri, 14 Jun 2002 10:13:26 GMT
I have previously used the source install of apache and utilized the
mod_auth_digest DSO to secure directories.  I decided to move to the
Redhat Linux 7.3 rpm install of apache (apache-1.3.23-11).  The rpm
install doesn't include the mod_auth_digest DSO.  I copied the DSO from
the source installed libexec directory into the rpm installed modules
directory and activated the module in the httpd.conf file.  When I start
apache I get:

[root@dawghouse apache_1.3.23 138]# /etc/init.d/apache start Starting
httpd: [Fri Jun 14 06:00:53 2002] [warn] Loaded DSO
modules/mod_auth_digest.so uses plain Apache 1.3 API, this module might
crash under EAPI! (please recompile it with -DEAPI) [  OK  ]

I figured copying the file wasn't the right way to do it so, I download
the apache 1.3.23 source and configured like so:

CFLAGS="-DEAPI" ./configure --enable-shared=max
--enable-module=auth_digest

I then copied the mod_auth_digest.so file that was created into the
modules directory of the rpm install (/etc/httpd/modules).  I still get
the message above when starting.  What gives?

Grant

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message