httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: mod_autoindex problems - before a bug report.
Date Fri, 10 May 2002 18:46:25 GMT

On Fri, 10 May 2002, Nimster wrote:
> Hey, thanks. The link you sent does indeed provide better insight on the
> nature of the problem, even if it's not exactly the issue I have. Since I
> understand you are some kind of authority on the issue, I am providing here
> info I got from debugging Apache using Visual Studio .NET trial version, and
> info on my VPN set-up.

Actually, I'm not much of an authority on this.  I just know a little here
or there.  The real authorities are Will Rowe and Bill Stoddard, and I
don't think either of them are on this list.

>
> The call stack, which I believe confirms your suspicion that the problem is
> somewhere with the API's points to NTDLL.DLL at 77f829e0() and has below it:

Hmm... Well, these are not network-related DLLs, so it could very well
just be apr (part of apache2) doing something nasty.

> Is there any more info I should send along with my Bug Report?

Looks pretty good to me.  The only other thing would be to compile a debug
build of apache so you could really see where the crash is occuring.  If
you want to try that, there are instructions here:
http://httpd.apache.org/docs-2.0/platform/win_compiling.html
It's relatively easy if you know visual studio well, but could be
challenging otherwise.

You should also include in your bug report the exact configuration changes
that are making to apache to generate the problem.

Joshua.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message