httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Vander Werf" <bru...@cyberlink.com>
Subject Apache Doesn't Process php Files
Date Thu, 23 May 2002 03:29:40 GMT

I am having trouble getting Apache to process php files through the PHP
interpreter. When I view a *.php file in a browser, I see my PHP source.

I am running Apache 1.3.20 on a RAQ4. The web server was installed before I
became involved in this project.

I have successfully installed PHP 4.1.2 and can run it interactively from
the command line. The php.ini file is in /etc/httpd.

I have the following lines in my httpd.conf file:

# Extra Modules
#LoadModule php_module modules/mod_php.so
#LoadModule php3_module modules/libphp3.so
LoadModule php4_module modules/libphp4.so

# Extra Modules
#AddModule mod_php.c
#AddModule mod_php3.c
AddModule mod_php4.c
AddModule mod_perl.c
#AddModule mod_casp2.c

AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php

The last two lines are actually in the VirtualHost section for the site that
I am trying to use.

I have restarted the web server several times.

What else do I need to check? What could be preventing Apache and PHP from
playing nice together?

--
Bruce Vander Werf
brucev@cyberlink.com


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message