httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billy" <m...@phenixcable.net>
Subject RE: httpd.conf fouled up
Date Sat, 25 May 2002 21:27:05 GMT


>  -----Original Message-----
>  From: David Jackson [mailto:david.j.jackson@pickledbeans.com]
>  Sent: Saturday, May 25, 2002 10:40 AM
>  To: users@httpd.apache.org
>  Cc: mysp@phenixcable.net
>  Subject: RE: httpd.conf fouled up
>
>
>  Billy --
>
>  > Remember. Someone else reinstalled apache with .rpm so it would go in
>  > the, "appropriate directories." Does this mean things like the log
>  > direcrory should be at /etc/httpd/log/?
>
>  You tell me, your on the box? Do the following (as root?):
>
>  find / -name httpd.conf

/usr/local/apache_1.3.24/conf/httpd.conf
/usr/local/apache/conf/httpd.conf
/usr/local/apacheold/conf/httpd.conf
/usr/local/apachebak/conf/httpd.conf
/etc/httpd/conf/httpd.conf

>  find / -name log -type d

/usr/log
/usr/share/doc/db3-devel-3.2.9/ref/log
/var/log
/var/qmail/supervise/qmail-send/log
/var/qmail/supervise/qmail-smtpd/log
/var/qmail/supervise/qmail-pop3d/log
/etc/tinydns/log

>  find / -name access_log

/usr/local/apache/logs/access_log
/usr/local/apacheold/logs/access_log
/usr/local/apachebak/logs/access_log
/var/log/httpd/access_log

>  find / -name error_log

/usr/local/apache/logs/error_log
/usr/local/apacheold/logs/error_log
/usr/local/apachebak/logs/error_log
/var/log/httpd/error_log

>  find / -name apachectl

/usr/local/apache_1.3.24/src/support/apachectl
/usr/local/apache/bin/apachectl
/usr/local/apacheold/bin/apachectl
/usr/local/apachebak/bin/apachectl
/usr/sbin/apachectl

>  run:
>  /path/apachectl configtest

OK. After intense deliberation with myself I have decided if someone else
(knowing what they are doing) installed frontpager server extensions
(patching apache from an rpm might change  lot of things) the apachectl
would remain in the same place at /usr/sbin no matter what. It will matter
not whether the /apache/old or the /apache/bak was MY original (installed at
/usr/local/apache), therefore when I run apachectl it should be from
/usr/sbin. And, in fact, that is where I /apachectl/graceful earlier. So the
output is;

Syntax OK.

(All that concern and I got syntax OK. Talk about anticlimatic!)

>  /path/apachectl start|restart


>
>  You might have to restart apachectl after makeing changes.
>  Check that the process is actually running? Look for httpd
>
>  ps aux |more

About a half-dozen.
>
>
>  Your going to have 1 - error and access log for the server.
>  and 1 each for your virutal hosts.
>  The error_log will give the error messages?

The error log for the server is	 (warning - warning - wrong place - wrong
place - --->>>   /var/log/hhtpd/error_log, the last few lines show the
restart;   (<<<--- warning - warning -  wrong place)

[Sat May 25 16:46:47 2002] [notice] SIGHUP received.  Attempting to restart
[Sat May 25 16:46:48 2002] [notice] Apache/1.3.23 (Unix)  (Red-Hat/Linux)
mod_ssl/2.8.7 OpenSSL/0.9.6b PHP/4.0.6 FrontPage/5.0.2.2510 configured --
resuming normal operations
[Sat May 25 16:46:48 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Sat May 25 16:46:48 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)

		^^^^^^^^^^^^^^^^^^^^^
<<<<< ----- Warning, Wrong place. ------ >>>>>

The correct error log /etc/httpd/logs/shows;

[Sat May 25 16:46:47 2002] [notice] SIGHUP received.  Attempting to restart
[Sat May 25 16:46:48 2002] [notice] Apache/1.3.23 (Unix)  (Red-Hat/Linux)
mod_ssl/2.8.7 OpenSSL/0.9.6b PHP/4.0.6 FrontPage/5.0.2.2510 configured --
resuming normal operations
[Sat May 25 16:46:48 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Sat May 25 16:46:48 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Sat May 25 16:57:03 2002] [notice] child pid 11558 exit signal Segmentation
fault (11)
[Sat May 25 17:03:45 2002] [notice] child pid 11559 exit signal Segmentation
fault (11)
[Sat May 25 17:03:52 2002] [notice] child pid 11560 exit signal Segmentation
fault (11)/

The corect directory, /etc/bicity.net-error.net shows for 5:09 PM;

[Sat May 25 17:09:32 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/root.exe
[Sat May 25 17:09:32 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/MSADC/root.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/c/winnt/system32/cmd.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/d/winnt/system32/cmd.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..%5c../winnt/system32/cmd.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist:
/var/www/html/bicity.net/_vti_bin/..%5c../..%5c../..%5c../winnt/system32/cmd
.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist:
/var/www/html/bicity.net/_mem_bin/..%5c../..%5c../..%5c../winnt/system32/cmd
.exe
[Sat May 25 17:09:33 2002] [error] [client 216.47.228.4] File does not
exist:
/var/www/html/bicity.net/msadc/..%5c../..%5c../..%5c/..Á../..Á../..Á../wi
nnt/system32/cmd.exe
[Sat May 25 17:09:34 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..Á../winnt/system32/cmd.exe
[Sat May 25 17:09:34 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..À¯../winnt/system32/cmd.exe
[Sat May 25 17:09:34 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..Áœ../winnt/system32/cmd.exe
[Sat May 25 17:09:35 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..%5c../winnt/system32/cmd.exe
[Sat May 25 17:09:35 2002] [error] [client 216.47.228.4] File does not
exist: /var/www/html/bicity.net/scripts/..%2f../winnt/system32/cmd.exe

The doamin-error_logs are not registering an error. (Error logs should be
"ServerRoot"/logs/bicity.net-error_log It (/etc/httpd/logs...shows no errors
since yesterday.
/etc/httpd/logs/access/bicity.net-access_log shows 404 three times yesterday
and nothing today.


 There is an appropriate index file here. However, when I went to the
>  > site with IE, it didn't happen. I cannot remember which error message
>  > it was. Right now there is /var/www/html/bicity.net/index.html. But, of
>  > course it still isn't working.
>
>  I.E shouldn't a have anything to do with it.
>  Look in error_logs for messages?
>  That's the index.html for that VirtualHost only.
>  Did you test the server before you added the virtualhost?
>  If not you might want to comment out bincity.net,
>  restart apache and see if it you can browse to the main
>  server page.
>
>
>  >>
>  >>  > <VirtualHost *>
>  >>  > 	ServerAdmin pm@mysp.net
>  >>  > 	documentRoot /var/www/html/bicity.net
>  >>  > 	ServerName bicity.net
>  >>  > 	ErrorLog /logs/bicity.net-error_log
>  >>  > 	customLog logs/bicity.net-access_log common
>  >>  > </VirtualHost>
>
>  Did you cut-and-paste this from httpd.conf? if so then changes:
>  documentRoot -> DocumentRoot
>  customLog -> CustomLog
>
>  And rerun apachectl configtest.
>
>
>  David
>
>
> Thanks for taknig the time to look at all this.
And thanks for your help.
Bill
>
>
>
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>  For additional commands, e-mail: users-help@httpd.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message