httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From farshid.dabesh-k...@bt.com
Subject RE: Starting apache and httpd.conf problem
Date Fri, 31 May 2002 14:41:29 GMT
Owen, 

Thank your for the advice, I have just tried exactly what you had mentioned
and I am still getting the same error.

I'm starting to wonder if it is anything to do with Solaris??? Also do I
need to make any changes to my PATH or CLASSPATH according to where the
mod_webapp.so file exists?

This is very puzzling, and since the error message contains "sparc" I am
guessing it may be something to do with Sparc Solaris.

Regards

Farshid


-----Original Message-----
From: Boyle Owen [mailto:Owen.Boyle@swx.com]
Sent: 31 May 2002 12:11
To: users
Subject: RE: Starting apache and httpd.conf problem


>I am having trouble with getting my apache installation to 
>load DSO modules
>(.so files).
>
>I have compiled web_app to link apache to tomcat and I have 
>copied over the
>created mod_webapp.so file into the modules folder of apache. 
>...
>Syntax error on line 217 of 
>/export/home/farshidd/apache/conf/httpd.conf:
>Cannot load /export/home/farshidd/apache/modules/mod_webapp.so 
>into server:
>ld.s.o.1: /export/home/farshidd/apache/bin/httpd: fatal: 
>relocation error:
>file /export/home/farshidd/apache/modules/mod_webapp.so: symbol
>apr_atomic_add_sparc: referenced symbol not found

Astonshingly, I have been doing the very same thing this week...

I think you have missed compiling the Apache Portable Runtime library. What
I did was:

- go to apr.apache.org and get the latest apr snapshot (it seems they do not
have a "release" system)
- unpack it in /tmp, then build it using:
	./buildconf
	./configure
	make

	Note that you need libtool to use buildconf - you can get this from
www.gnu.org..

- now when you compile webapp, you should say:

	./configure --with-apxs --with-apr=/tmp/apr

	and it will pick up the libraries when building. As far as I
understand, the APR libs are compiled into webapp.so so you don't need to
keep APR..

Rgds,

Owen boyle

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message