httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From farshid.dabesh-k...@bt.com
Subject Starting apache and httpd.conf problem
Date Fri, 31 May 2002 10:18:30 GMT
Hi,

I am having trouble with getting my apache installation to load DSO modules
(.so files).

I have compiled web_app to link apache to tomcat and I have copied over the
created mod_webapp.so file into the modules folder of apache. I have also
edited the httpd.conf file by adding:

LoadModule webapp_module modules/mod_webapp.so

The file exists in the modules directory but I get an error saying that
there is a syntax error on the line above in the httpd.conf file. Here is
the error message:

Syntax error on line 217 of /export/home/farshidd/apache/conf/httpd.conf:
Cannot load /export/home/farshidd/apache/modules/mod_webapp.so into server:
ld.s.o.1: /export/home/farshidd/apache/bin/httpd: fatal: relocation error:
file /export/home/farshidd/apache/modules/mod_webapp.so: symbol
apr_atomic_add_sparc: referenced symbol not found

What could I be doing wrong? In my eyes everything is how it should be and
apache starts when I take out the LoadModule... line. I am using apache
2.0.35 on Solaris 2.8.

Any help will be most appreciated.

Farshid

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message