httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay Turberville" <...@studio522.com>
Subject Re: Enabling CGI on Apache 1.3.23
Date Fri, 03 May 2002 14:50:03 GMT
I could easily be wrong, but I don't think "EOF" be in quotes?  

print <<"EOF";

should be <<EOF;

Jay Turberville

<snip> 
> [Fri May  3 03:30:09 2002] [error] (2)No such file or directory: exec of
> /var/www/cgi-bin/test.pl failed
> [Fri May  3 03:30:09 2002] [error] [client 192.168.1.1] Premature end of
> script headers: /var/www/cgi-bin/test.pl
> 
> This is a copy of the test.pl file I'm trying to run:
> **********************************************************
> 
> #!/usr/bin/perl
> 
> # hello.pl -- my first perl script!
> 
> print "Content-type: text/html\n\n";
> 
> print <<"EOF";
> <HTML>
> 
> <HEAD>
> <TITLE>Hello, world!</TITLE>
> </HEAD>
> 
> <BODY>
> <H1>Hello, world!</H1>
> </BODY>
> 
> </HTML>
> EOF
> 
> The script works fine when run from shell but can't be access from my
> website. Here is the error I get when I to run it from the browser:
> ************************************************************************
> *************************************************
> Internal Server Error
> The server encountered an internal error or misconfiguration and was
> unable to complete your request.
> Please contact the server administrator, root@localhost and inform them
> of the time the error occurred, and anything you might have done that
> may have caused the error.
> 
> More information about this error may be available in the server error
> log.
> 
> 
> 
> ------------------------------------------------------------------------
> --------
> 
> Apache-AdvancedExtranetServer/1.3.23 Server at Mithrilhall.Linux Port 80
> 
<snip>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message