httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Divyank Turakhia" <divyan...@directi.com>
Subject Suexec and Virtual Hosts
Date Sat, 04 May 2002 10:48:18 GMT
I just cant seem to get suexec to work.

I tried and tried with apache 2 .0.35 and gave up. Then I decided to try
it with apache 1.3.24. This too dosent work and gives me the same error
so its obvioud tht I am making some mistake.

This is how I installed apache 1.3.24:
./configure --prefix=/usr/local/apache --disable-rule=IRIXN32
--enable-module=speling --enable-module=so --enable-suexec
--suexec-caller=99 --suexec-docroot=/domains --suexec-uidmin=500
--suexec-gidmin=500
make
make install
strip /usr/local/apache/bin/httpd

Where User nobody has uid=99.

My Main httpd.conf runs as:
User nobody
Group nobody

<VirtualHost 192.168.1.192>

ServerName www.test33.com
ServerAdmin apacherrors
DocumentRoot /domains/www.test33.com/web

User test33
Group site47
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
<Directory /domains/www.test33.com/web/>
    Options FollowSymLinks ExecCGI Indexes Includes MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
</Directory>
</VirtualHost>

My suexec starts when I start apache as I get "[Sat May  4 16:05:04
2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/local/apache/bin/suexec)" in my error_log file

When I try to run a simple hello world .pl file I get a "Premature end
of script headers: /domains/www.test33.com/web/hello.cgi" and the below
error in suexec_log:
[2002-05-04 16:18:56]: crit: calling user mismatch (nobody instead of
99)

If I Remove the User and Group directive from the <VirtualHost> then it
works fine with no errors

These are the permission of the file:
drwxr-sr-x    2 test33   site47       4096 May  3 22:46 .
drwxr-sr-x    4 test33   site47       4096 May  3 22:27 ..
-rwxr-xr-x    1 test33   site47         76 May  3 22:44 hello.cgi

Can anyone please tell me where I am going wrong


Thanks,
Divyank



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message