httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rich Bowen <rbo...@rcbowen.com>
Subject Re: I get a pop up window everytime a cgi script is launched (2.0.35 windows 2000)
Date Mon, 08 Apr 2002 10:40:15 GMT
On Sun, 7 Apr 2002, Frederic Mancuso wrote:

> I just upgraded to apache 2.0.35 on windows 2000 and I get a pop up window
> everytime a cgi script is launched. My scripts have the usual
> #!C:\perl\bin\perl.exe header. The popup windows are titled
> "C:\perl\bin\perl.exe" and stay open during the whole execution of the
> script. This happens only when apache is running from the command prompt not
> when it is running as a service. Am I missing something?

When Apache is running as a console app (from the command prompt) and
you run a CGI program, Windows launches a new console in which to run
the Perl program. What's really fun is to run Win32::OLE apps that
launch larger applications, like, say, Excel. (Yes, I've done it. No, I
don't recommend it.) When you're running as a service, everything runs
"in the background" and so this does not happen.

Yeah, this is strange, but it is perfectly expected behavior.

-- 
Rich Bowen - rbowen@rcbowen.com
... and another brother out of his mind, and another brother out at New
York (not the same, though it might appear so)
	Somebody's Luggage (Charles Dickens)


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message