httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frederic Mancuso" <manc...@rimes.com>
Subject Problems with Aliasing an UNC share under windows 2000
Date Wed, 10 Apr 2002 13:38:43 GMT
Apache 2.0.35 on windows seems to have a difficult time with aliasing a UNC
path.

I want to alias the /temp to a shared drive that contains temporary images.
The urls that are requested look like /temp/123456789123456789.gif.
I have tried several ways without success.
All worked fine with 1.3.20.


*) With the following directive :

Alias /temp "//quadserv/temp"

It works for a while and then I start getting an error message at random :

[Tue Apr 09 18:38:51 2002] [error] [client 10.0.1.118] File does not exist:
D:/WEBDOCS/temp


*) With the following directive :

Alias /temp/ "//quadserv/temp/"

It works for a while and then I start getting too kind of errors at random :

[Wed Apr 10 09:25:26 2002] [error] [client 10.0.1.118] (22)Invalid argument:
dir_walk error, could not determine the root path of filename
//quadserv/webtemp/1018445125131500244.gif//quadserv/webtemp/101844512513150
0244.gif for uri /temp/1018445125131500244.gif, referer: http://fred02/...

[Wed Apr 10 09:27:31 2002] [error] [client 10.0.1.118] File does not exist:
D:/WEBDOCS/temp, referer: http://fred02/...


Either way it looks like apache looses the aliasing and just keeps looking
for a local /temp.

Any suggestions?

Thanks. Frederic Mancuso.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message