httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Admin" <kompu...@naisp.net>
Subject RE: Apache 2.0.35 on Win 2k / CGI
Date Fri, 26 Apr 2002 01:59:42 GMT
ok...I think i know what the problem is:

the shebang line path is different for windows...in that...
the "slash" is backwards , instead of frontwards...

instead of this:
#!C:/perl/bin/perl.exe

it should be this:
#!c:\perl\bin\perl.exe



-----Original Message-----
From: Octavian Rasnita [mailto:orasnita@home.ro]
Sent: Thursday, April 25, 2002 9:18 PM
To: users@httpd.apache.org
Subject: Re: Apache 2.0.35 on Win 2k / CGI


I also found that in Apache 2 I need to change the shebang line to:
#!C:/perl/bin/perl.exe
This way it works.
I need to use the .exe extension in the shebang line because otherwise it
won't work.
And it doesn't work anymore with:
#!/perl/bin/perl


Teddy,
orasnita@home.ro

----- Original Message -----
From: "Dave Findlay" <dave@cameronfindlay.com>
To: <users@httpd.apache.org>
Sent: Thursday, April 25, 2002 11:55 PM
Subject: RE: Apache 2.0.35 on Win 2k / CGI


Also, to confuse this issue, if I run any of my scripts I get (ie other than
printenv.pl):
Error message:
couldn't create child process: 22503: C:/.../mine.pl

The only difference I can see is my shebang line is configured for unix, but
I have the
ScriptInterpreterSource registry

entry in my httpd.conf. The 2.0 docs say this is still valid, but it does
not appear to be working for me.

-----Original Message-----
From: Dave Findlay [mailto:dave@cameronfindlay.com]
Sent: Thursday, April 25, 2002 2:50 PM
To: users@httpd.apache.org
Subject: RE: Apache 2.0.35 on Win 2k / CGI


Oddly, if I make the URL http://127.0.0.1:8888/printenv.pl/ it executes
correctly, but why on earth would I have to add a slash on the end?

-----Original Message-----
From: Dave Findlay [mailto:dave@cameronfindlay.com]
Sent: Thursday, April 25, 2002 2:29 PM
To: users@httpd.apache.org
Subject: RE: Apache 2.0.35 on Win 2k / CGI


I tried copying printenv.pl to htdocs, adding the ExecCGI and adding
AddHandler cgi-script .pl but it still tries to download it.

Thanks,
Dave

-----Original Message-----
From: Fernando Reuter Wendt [mailto:fernando@admijui.unijui.tche.br]
Sent: Thursday, April 25, 2002 2:21 PM
To: 'users@httpd.apache.org'
Subject: RES: Apache 2.0.35 on Win 2k / CGI


Take a look at the Directory /htdocs

I have included 'ExecCGI' directive and it works. Maybe it works...

So long,

+---------------------
 Fernando A. R. Wendt


-----Mensagem original-----
De: Dave Findlay [mailto:dave@cameronfindlay.com]
Enviada em: quinta-feira, 25 de abril de 2002 17:14
Para: users@httpd.apache.org
Assunto: Apache 2.0.35 on Win 2k / CGI


I cannot get any kind of CGI working with Apache 2 on my Win 2k box.
I had it all working perfectly with 1.3.22 but now nothing works at all.
I have tried to go back to basics and just get printenv.pl working from the
default cgi-bin, but instead of executing the script it tries to download
it.

Any ideas?

Thanks,
Dave


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message