httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Klein <kl...@loyno.edu>
Subject Build 2.0 on aix
Date Tue, 09 Apr 2002 15:42:44 GMT
I am trying to build apache-2.0.35 on aix 5.1L with ML 1 installed. I do a 
./configure --prefix=/usr/local/apache2 and can see no problem in the 
configuration output. However, when I do the make, I get a list of errors 
relating to pthreads!

        /bin/sh /home/root/dev/httpd-2.0.35/srclib/apr/libtool --silent 
--mode=link gcc  -g -O2
    -U__STR__ -D_USE_IRS -D_THREAD_SAFE -DAP_HAVE_DESIGNATED_INITIALIZER 
-I. -I/home/root/dev
/httpd-2.0.35/os/unix -I/home/root/dev/httpd-2.0.35/server/mpm/prefork 
-I/home/root/dev/httpd-2
.0.35/modules/http -I/home/root/dev/httpd-2.0.35/modules/proxy 
-I/home/root/dev/httpd-2.0.35/in
clude -I/home/root/dev/httpd-2.0.35/srclib/apr/include 
-I/home/root/dev/httpd-2.0.35/srclib/apr
-util/include -I/home/root/dev/httpd-2.0.35/modules/dav/main 
-I/home/root/dev/httpd-2.0.35/srcl
ib/apr-util/include 
-I/home/root/dev/httpd-2.0.35/srclib/apr-util/xml/expat/lib -export-dynamic
 -Wl,-brtl   -o htpasswd  htpasswd.lo -Wl,-brtl -Wl,-uXML_Parse 
/home/root/dev/httpd-2.0.35/src
lib/apr-util/libaprutil.la 
/home/root/dev/httpd-2.0.35/srclib/apr/libapr.la -lm /home/root/dev
/httpd-2.0.35/srclib/apr-util/xml/expat/lib/libexpat.la


ld: 0711-317 ERROR: Undefined symbol: .pthread_mutex_unlock
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutex_destroy
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutexattr_init
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutex_init
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutexattr_destroy
ld: 0711-317 ERROR: Undefined symbol: .pthread_attr_init
ld: 0711-317 ERROR: Undefined symbol: .pthread_attr_setdetachstate
ld: 0711-317 ERROR: Undefined symbol: .pthread_attr_getdetachstate
ld: 0711-317 ERROR: Undefined symbol: .pthread_create
ld: 0711-317 ERROR: Undefined symbol: .pthread_self
ld: 0711-317 ERROR: Undefined symbol: .pthread_exit
ld: 0711-317 ERROR: Undefined symbol: .pthread_join
ld: 0711-317 ERROR: Undefined symbol: .pthread_detach
ld: 0711-317 ERROR: Undefined symbol: .pthread_once
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutex_lock
ld: 0711-317 ERROR: Undefined symbol: .pthread_mutex_trylock
ld: 0711-317 ERROR: Undefined symbol: .pthread_sigmask
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more 
information.
collect2: ld returned 8 exit status
make: 1254-004 The error code from the last command is 1.


How can I resolve this or simply not use threads?

Thanks


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message