httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Reichenbacher <fr...@mollynet.com>
Subject Re: frontpage extensions configuration
Date Sat, 20 Apr 2002 21:02:10 GMT
Don't copy the exes into the virtual host directories, just set up a
script alias in your virtual host directives pointing to them:

ScriptAlias /_vti_bin/_vti_adm/ /var/www/html/_vti_bin/_vti_adm/
ScriptAlias /_vti_bin/_vti_aut/ /var/www/html/_vti_bin/_vti_aut/
ScriptAlias /_vti_bin/ /var/www/html/_vti_bin

Like so, the extensions won't run without them. It looks to me like the
permissions are set up correctly. However, to be sure, chown
ndedecke:users -fR /path/to/mydomain.com. It has to be owned by the
frontpage user:group, not the apache user:group.

Frank Reichenbacher



Nick De Decker wrote:
> 
> Hello,
> 
> Thanks for the help about getting frontpage extensions for apache under
> linux.
> Finally i got them installed.... man that microsoft installscript really
> sucks :)
> 
> Anyway, now i've got several virtualhosts in my httpd.conf and i install the
> frontpage extensions for each virtualhost like this : (frontpage 2002
> extensions)
> 
> ./owsadm.exe -o install -servconf=/usr/local/apache/conf/httpd.conf -xuser
> ndedecke -xgroup users -u webadmin -p 80 -m mydomain.com
> 
> => now it installs the following in the docroot of the vhost :
> -rw-rw-r--    1 ndedecke inpeach       367 Apr 20 22:04 .htaccess
> drwx------    2 ndedecke users        4096 Apr 20 22:04 images/
> -rw-------    1 ndedecke users        2451 Apr 20 22:04 postinfo.html
> drwx------    2 ndedecke users        4096 Apr 20 22:04 _private/
> drwx------    4 ndedecke users        4096 Apr 20 22:04 _vti_bin/
> drwx------    2 ndedecke users        4096 Apr 20 22:04 _vti_cnf/
> -rw-------    1 ndedecke users        1754 Apr 20 22:04 _vti_inf.html
> drwx------    2 ndedecke users        4096 Apr 20 22:04 _vti_log/
> drwx------    2 ndedecke users        4096 Apr 20 22:04 _vti_pvt/
> drwx------    2 ndedecke users        4096 Apr 20 22:04 _vti_txt/
> 
> In the virtualhost section of that host in httpd.conf i got "User ndedecke"
> and "Group users" directives.
> 
> Now the problem is i can't connect with my frontpage to the server because
> the permissions aren't set right.
> Who can tell me how i have to set the owner/group of all those directories
> and files so that everything runs secure. Should i use the apache user/group
> in the -xuser and -xgroup arguments or the user where the virtualhost
> belongs to ?
> 
> Another thing : in some docs on the ready-to-run site i found something that
> said i had to copy some vti_bin with some exe files in it to each
> virtualhost, why is that, what exes's, or is this just bull :)
> 
> What about apache showing the contents of the special frontpage directories
> ? i see that frontpage stores the password there so i guess it must be kept
> hidden/unreadable :)
> 
> Regards,
> Nick
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message