httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject Re: cgi question
Date Tue, 09 Apr 2002 15:06:11 GMT
Admin wrote:
> 
> yes...it's odd...only if you have failed to add the handler/ext " .pl " to that line
> DUHHHHH   and THATS exactly why...he is getting the error...
> look again at the extension on the filename...it is:  "cart.pl"
> not cart.cgi

Look at the error message. This is not what happens if you make the
mistake you are describing. 

> [Tue Apr  9 08:42:50 2002] [error] (8)Exec format error: exec of
> /var/www/html/snowbankih/cgi-bin/ihcparts/cart.pl failed

As I stated in a direct reply, this is caused bby a faulty shebang line
trapping a system error.

If you request a file which is supposed to be a CGI but you haven't
defined it as a CGI with AddHandler or ScriptAlias, apache will assume
it is a plain file and simply serve it so the client will just get the
perl script in his browser. You will not get an "Exec format error".

There's no need to get all hot under the collar - we're all trying to
help one another here!

Rgds,

Owen Boyle.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message