httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject Re: Change in CGI config for 2.0.x? @@!$!@$!#$
Date Thu, 04 Apr 2002 08:29:48 GMT
Brian Capouch wrote:
> 
> Owen Boyle wrote:
> >
> >
> > You didn't answer the $1,000,000 question - does the script output a CGI
> > header before anything else???
> >
> 
> /usr/local/apache/cgi-bin $ ./test-cgi
> Content-type: text/plain
> 
> CGI/1.0 test script report:
> . . .  blah blah blah. . .
> tons of output . . .
>  . . . .
> 
> I hope that's the right answer to the question. . .

10/10. Not outputting a proper header is the commonest cause of a
"Premature end of script headers.." error. Now that we've disposed of
that...

Activate scritplogging to get more information. To do this:

- create a file, e.g. logs/script_log, belonging to the apache User
(this is important, unlike other logfiles, this one must be writeable by
apache user - not just by root).
- define "ScriptLog logs/script_log" in the config.
- restart

Now you should trap the error messages from the CGI in this file and
this will hopefully let you see what's going wrong.

Given that the scripts work with another version of apache, could be a
problem with the CGI.pm module.

Rgds,

Owen Boyle.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message