httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Reichenbacher <fr...@mollynet.com>
Subject Re: Script log not logging
Date Wed, 03 Apr 2002 03:11:06 GMT
Thank you Owen, however, there is more to it. I did what you suggested
but it still didn't work. It worked fine, however, after I omitted the
pipe to rotatelogs, which ScriptLog apparently does not like one single
bit. The lack of log rotation is tolerable, of course, since ScriptLog
should really only be used for debugging. I suppose rotatelogs can't be
used because it runs as root.

Frank


Owen Boyle wrote:
> 
> Frank Reichenbacher wrote:
> >
> > www_error_log and www_access_log are correctly generated, rotated, and
> > logged, but cgi_log does not appear...
> 
> ScriptLogging is a little tricky. The main difference with the error_log
> and transfer_log is that the logfile must be owned (or at least
> writeable) by the apache User - i.e. not just by root. Secondly, the
> file must exist before apache is started (it won't be created).
> 
> I usually do:
> 
> - login as apache User
> - touch cgi_log
> - su
> - start apache
> 
> rgds,
> 
> Owen Boyle.
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message