httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Hawkes <ahaw...@unicon.net>
Subject Re: (32538)Socket operation on non-socket
Date Tue, 16 Apr 2002 15:02:24 GMT
Did you do as it says and "Check the FAQ"?

http://httpd.apache.org/docs/misc/FAQ.html#WSADuplicateSocket

-Andy

On Tue, 16 Apr 2002 09:44:27 -0500
"Darren Winter" <dwinter5@earthlink.net> wrote:

> 
> I've installed/uninstalled/reinstalled Apache 2.0.35 now about 10 times
> and I've spent tons of time setting up http.conf each time.  I test the
> conf file and it reports Syntax OK every time.
> 
> I've tried setting it up for all users on port 80, I've tried setting it
> up for the current user only on port 8080.  Nothing works!
> 
> "C:\Program Files\Apache Group\Apache2\bin\Apache.exe" -f "C:\Program
> Files\Apache Group\Apache2\conf\httpd.conf" -d "C:\Program Files\Apache
> Group\Apache2\."
> 
> error.log:
> 
> [Tue Apr 16 08:25:44 2002] [notice] Parent: Created child process
> -797981[Tue Apr 16 08:25:44 2002] [notice] Child -797981: Child process
> is running[Tue Apr 16 08:25:45 2002] [crit] (32538)Socket operation on
> non-socket: Parent: WSADuplicateSocket failed for socket 6653280. Check
> the FAQ.[Tue Apr 16 08:25:45 2002] [crit] master_main: create child
> process failed. Exiting.
> [Tue Apr 16 08:25:45 2002] [crit] (22609)The pipe has been ended.  :
> setup_inherited_listeners: Unable to read socket data from parent
> [Tue Apr 16 08:25:45 2002] [notice] Parent: Forcing termination of child
> process 6660700
> 
> If I install 1.3.23 everything works like a charm, but 2.0.35 will not
> run at all for me.  I've tried on 3 different Windows98 SE boxes, all
> running different versions of Internet Explorer (5.01 SP2, 5.50 SP1,
> 6.0).
> 
> I'd also like to mention that I tried two earlier versions of 2.0.x with
> the same exact results, and also if you look for this error message on
> Google you will see a few other people complaining about it - but the
> people that responded tried making it seem like the end user did
> something wrong, like trying to use a 1.x conf file on a 2.x server. 
> That is not the case, I assure you!
> 
> I tried getting 2 friends up to this new version, same headache for them
> too!
> 
> I just don't get it.  Everyone raves about 2.0.x, but I haven't seen it
> run once.  I'm pretty technically inclined, but after wasting 3 or 4
> hours of my time it makes me wonder if others are just bragging about
> how nice it is even though they can't get it running either - at least
> then they can save face.
> 
> Any ideas?  Surely I'm not the only one having problems.
> 
> Thanks in advance!

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message