httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McIlhargie, Rob" <Rob.McIlhar...@exchange.webmd.net>
Subject RE: Problem getting 2.0.32 to start using Solaris 8 (with IPv4 an d IPv6)
Date Thu, 04 Apr 2002 20:30:53 GMT

	I'm also having the exact same problem that you describe. I'm
using Solaris 8, gcc 3.0.1 and Apache httpd 2.0.32. Here is the last
part of the output from truss when it gets to the point where it
hangs.

brk(0x0010DCF0)                                 = 0
brk(0x0010DCF0)                                 = 0
brk(0x0010FCF0)                                 = 0
setsockopt(3, 65535, 4, 0xFFBEF7F4, 4, 1)       = 0
setsockopt(3, 65535, 8, 0xFFBEF7F4, 4, 1)       = 0
setsockopt(3, 6, 1, 0xFFBEF7EC, 4, 1)           = 0
bind(3, 0x0008EE24, 32, 3)                      = 0
listen(3, 511, 1)                               = 0
pipe()                                          = 5 [6]
fcntl(5, F_GETFL, 0x00000000)                   = 2
fstat64(5, 0xFFBEF780)                          = 0
fstat64(5, 0xFFBEF780)                          = 0
fcntl(5, F_SETFL, 0x00000082)                   = 0
lwp_sema_wait(0x00087B18)       (sleeping...)
signotifywait()                 (sleeping...)
lwp_cond_wait(0xFF0755B0, 0xFF0755C0, 0xFF035BF0) (sleeping...)
door_return(0x00000000, 0, 0x00000000, 0) (sleeping...)


It hangs after door_return(). There is a lot more truss output
but I did not want to flood the mailing-list with it.

My httpd.conf file is almost the same as the stock conf
file that came with Apache. I'm not running any special 
modules and am using IPv4 for networking.

-- Rob.

> -----Original Message-----
> From: Carl Brewer [mailto:carl@bl.echidna.id.au]
> Sent: Wednesday, April 03, 2002 6:24 PM
> To: users@httpd.apache.org
> Subject: Problem getting 2.0.32 to start using Solaris 8 
> (with IPv4 and
> IPv6)
> 
> 
> 
> 
> I've flicked through the archives, and google etc, but found 
> nothing on 
> this.
> 
> I'm trying to get 2.0.32 to start on a Sun SPARC10/512 (2 x 32bit
> SPARC chips), running Solaris 8 with IPv6 and IPv4.
> 
> I'm using gcc version 3.0.2 to compile it, with the options
> ./configure --prefix=/opt/local/apache-2
> 
> It seems to compile and install just fine, and I've run older 
> versions 
> of apache with no problems (including Kame patched 1.3 variants to get
> IPv6 support).
> 
> But, when I start it, it hangs.  netstat -a shows it's listening to
> port 80 on both IPv4 and IPv6, and I can telnet to port 80 and I
> don't get a connection refused, but I also don't ever get a response 
> from the server.
>
[SNIP] 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP 
> Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message