httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Hyland" <ben.hyl...@liv-coll.ac.uk>
Subject Mod_proxy problems with Hotmail and other sites
Date Wed, 24 Apr 2002 15:47:01 GMT
Hi folks,
I've got mod_proxy with Apache 1.3.24 on Win2K Server proxying a few
hundred clients, no cacheing.
Most sites are fine, but Hotmail and Yahoo Mail won't let proxied
clients log on - you enter your username and password, it accepts the
username but keeps asking for the password. The error.log reports a 302
error (data requested has a different URL temporarily). It works fine on
Apache 2 so I'm assuming it's an http 1.0 issue. I can't move to 2.0
however as I'm logging the proxy to a MySQL db through mod_perl, which I
can't get going under Apache 2.0.
The proxy is going through our firewall which is NATting the usual
ports. Other cookie-dependent sites work ok under the proxy as do SSL
sites, so I don't think it's anything to do with that. Windows Update
won't work on either Apache.

The thing that's giving me hope is that I can find very few mentions of
this on Google/Deja, leading me to believe that it's something foolish
that I'm doing that can be fixed with a simple line in the config.
Please?

TIA,

Ben


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message