httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Nelson" <pete.nel...@ci.stpaul.mn.us>
Subject Re: php & apache problem
Date Mon, 04 Mar 2002 14:08:04 GMT
I'm grinding my teeth reading your message - it brings up some painful memories.

It looks like your rebuild of php didn't work, so your new php module can't be loaded.  This
can happen for a number of reasons, but I've usually found it to be a linked library that
apache couldn't load.  For my part, I usually start changing my options to php-4.x.x/configure
until I get it to work (often a frustrating endevor - but after a certain amount of time and
the right incantation of 4-letter words, I've usually gotten it to work).

I've only been able to overcome this by trial and error, and have little advice to give you
other than doing the same.  However, since this is really a php question more than an apache
question, you may want to try a php mailing list - see http://www.php.net/

--
Pete Nelson, Web Developer
<pete.nelson@ci.stpaul.mn.us>
http://www.ci.stpaul.mn.us/

>>> apache@ring-wraith.com 03/03/02 03:56PM >>>
hi there,

i configured and "make", "make install" php, but now i allways get the following error, when
i try to start apache:


"Syntax error on line 210 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/lib/libz.soø
                                                                               : shared object
not open
/usr/local/apache/bin/apachectl start: httpd could not be started"


How can i get php to work with apache?

Regards,

Duncan




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message