httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Henry" <bryan.he...@mail.utexas.edu>
Subject RE: Configuring Apache Virtual Hosts
Date Thu, 07 Mar 2002 14:47:05 GMT
are you trying to:
point http://your.website.com 	-> to /var/www/html
and   http://your.website.com/www 	-> to /home/duce/www/
??  no??

If you are trying to:
point http://your.website.com 	-> to /home/duce/www/

then set your .conf file with this
DocumentRoot "/home/duce/www" 	<- note, no trailing slash

~ bryan




-----Original Message-----
From: Daugherty, William [mailto:WDaugherty@fictx.com]
Sent: Thursday, March 07, 2002 8:03 AM
To: 'users@httpd.apache.org'
Subject: Configuring Apache Virtual Hosts


All,

Well first I would like to say hello and then thanks for being here to
assist people like me with our apache issues.  Now I will give you
background on my setup then describe the issue I am having.  I am running a
Mandrake Linux 8.1 and installed Apache Extranet Server Product ver. 1.3.19
during install of the OS.  Apache does currently work when trying to serve
up a single page from /var/www/html directory.  However I do appear to be
having great difficulty when attempting to create virtual name hosts.  I
have also changed my DNS entry for this www virtual host to CNAME record
instead of A record as I thought this might have had some bearing but
evidently not.

When I go into my httpd.conf file (which resides in /etc/httpd/conf) and go
to configure a vhost it tells me (commented) that they have created a
separate file for creating vhosts @ ./vhosts/Vhost.conf and I should make my
modifications there.  I have created a new directory for my new virtual host
(www) to be served at /home/duce/www/ and I place a test 'index.htm' file in
that directory so I could see when it was configured properly.  When I
create the virtual name host entry in the Vhost.conf file I save the file
and I get out 'vi' to try accessing the page from a browser.  The page
automatically shows me the default apache 'index.htm' instead of the one I
had previously placed in the directory.  This to me suggests that the
Virtual host is still pointing to the file /var/www/html/index.htm instead
of /home/duce/www/index.htm .  I am greatly frustrated and would appreciate
any help I can get even if it is only a virtual smack up side the head.  I
have read the O'Reily book on installing and configuring Apache in my
attempts to configure this piece (Virtual Hosts) and I have configured the
'.conf' the way the book has said but so far I have had no visible success.
Can anyone help me?

Thanks,

Bill

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message