httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "active active" <kublaka...@hotmail.com>
Subject Frontpage Extensions 2002 on Apache 1.3.23 under FreeBSD - need help
Date Sun, 17 Mar 2002 23:57:29 GMT
Hi Everyone
I spent the last few days trying to install Frontpage Extensions 2002 on 
FreeBSD. I did considerable research and was able to fix a lot of errors 
along the way. But now it seems I am finally stuck. Please help. I am going 
to describe below exactly what I did in detail, hoping that someone could 
read it and either tell me what I did I wrong or most probably what I 
missed. You can reply on this forum or if  you could cc me your reply to 
kublakan60@hotmail.com, I'd really really appreciate it.
Here goes:



I am running FreeBSD 3.3-RELEASE #13.
I had mod_frontpage.c version 1.6.1. I got it from
http://people.freebsd.org/~mbr/distfiles/mod_frontpage-1.6.1.tar.gz

I got fp-patch-apache_1.3.22 from
ftp://ftp.rtr.com/pub/fp-patch-apache_1.3.22.Z   -  I patched my source of 
apache with it like this:

patch p0 <fp-patch-apache_1.3.22

I did this in the source directory of apache.
I installed Apache 1.3.23 with static support for perl and php.  This is the 
command I used to compile the apache server.

./configure --with-layout=Apache --prefix=/usr/local/apache23 
--enable-module=so --enable-module=rewrite --enable-module=auth_dbm 
--enable-suexec --suexec-uidmin=100 --suexec-gidmin=100 
--suexec-docroot=/web1/users 
--activate-module=src/modules/fastcgi/libfastcgi.a 
--activate-module=src/modules/php4/libphp4.a 
--activate-module=src/modules/perl/libperl.a --add-module=mod_frontpage.c

I ran fp_install.sh but I did not replace my httpd with their stock 1.3.19 
httpd without any of my modules. I kept my httpd with mod_frontpage.c module 
enabled.

I installed apache to /usr/local/apache23/ because I still have an old 
functioning version of apache for backup purposes in /usr/local/apache.
The homepage of the user who needs to have it installed is in 
/web1/users/u370/docs. After installation nothing changed in the httpd.conf 
file for some reason.

This is an excerpt from the apache log after it started:

[notice] FastCGI: wrapper mechanism enabled (wrapper: 
/usr/local/apache23/bin/suexec)
[notice] FastCGI: process manager initialized (pid 8361)
[notice] Apache/1.3.23 (Unix) FrontPage/5.0.2.2623 mod_perl/1.26 PHP/4.1.2 
mod_fastcgi/2.2.12 configured - resuming normal operations
[notice] suEXEC mechanism enabled (wrapper: /usr/local/apache23/bin/suexec)
[notice] Accept mutex: flock (Default: flock)

This shows that everything is enabled.

Then I ran command:
./owsadm.exe -o setadminport -s /usr/local/apache23/conf/httpd.conf -port 
8090 -username admin -pw password

That added the following lines to the httpd.conf
Listen 8090
Listen 80

<VirtualHost _default_:8090>
DocumentRoot /usr/local/frontpage/version5.0/admin-exes
DirectoryIndex fpadmcgi.exe
<Directory /usr/local/frontpage/version5.0/admin-exes/>
       AddHandler cgi-script .exe
       Options ExecCGI
</Directory>
</VirtualHost>



User370 has domain mydomain.com and his httpd.conf entry looks like this:

<VirtualHost 192.168.0.15>
DocumentRoot    /web1/users/u370/docs
ServerName      mydomain.com
ServerAdmin     root@mydomain.com
LogFormat       "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" 
\"%{User-agent}i\""
TransferLog     /web1/www-logs/u370/access_log
ErrorLog        /web1/www-logs/u370/error_log
User    u370
Group   u370
ScriptAlias     /cgi-bin/ /web1/users/u370/docs/cgi-bin/
Alias   /site-stats /web1/http-stats/u370/
</VirtualHost>

So, now I tried adding the Frontpage 2002 extensons support for that user. I 
tried it using this command:
./owsadm -o install -s /usr/local/apache23/conf/httpd.conf    -p 8090 -m 
mydomain.com -u u370 -pw password -xu www -wg www

But here it gave me this error:
Note: Local version of Apache must use the FrontPage Apache patch.
Error: 'mydomain.com:8090' server is not a valid virtual server.

I didn't know what to do at this point. I tried going to 
http://mydomain.com:8090 but it gave me an error saying - unauthorized 
access. So I edited the httpd.conf entry to look like this:
<VirtualHost _default_:8090>
DocumentRoot /usr/local/frontpage/version5.0/admin-exes
DirectoryIndex fpadmcgi.exe
<Directory /usr/local/frontpage/version5.0/admin-exes/>
	AllowOverride All
	Order allow,deny
	Allow from all
	AddHandler cgi-script .exe
	Options ExecCGI
</Directory>
</VirtualHost>


I basically added these options:
	AllowOverride All
	Order allow,deny
	Allow from all

Now when I went to http://mydomain.com:8090 - it gave me a login prompt. I 
logged in with l: admin p: password. And was able to extend the server to 
mydomain.com. This created these directories in /web1/users/u370/docs

drwxr-xr-x   4 u370  u370    512 Mar 17 13:47 _vti_bin
drwxr-xr-x   2 u370  u370  22528 Mar 17 13:48 _vti_cnf
-rw-r--r--   1 u370  u370   1754 Mar 17 13:47 _vti_inf.html
drwxr-xr-x   2 u370  u370    512 Mar 17 13:47 _vti_log
drwxr-xr-x   2 u370  u370    512 Mar 17 13:48 _vti_pvt
drwxr-xr-x   2 u370  u370    512 Mar 17 13:47 _vti_txt

with various .htaccess files and other _vti files and subdirectories in 
them. However, the user still cannot publish using frontpage and the command
./owsadm.exe -o install          -s /usr/local/apache23/conf/httpd.conf    
-p 8090 -m mydomain.com  -u u370 -pw password -xu www -wg www

still doesn't work.
What am I doing wrong? There were no other changes to the default 
httpd.conf. Should there be any other entries there that let that user use 
Frontpage Extensions? Any other command I forgot to run? I wrote exactly 
what I did, above.

Any tips, help, comments, suggestions would be greatly appreciated. I spent 
so much time on this already.

I used these sites as reference:

http://suso.suso.org/docs/apache_and_frontpage/htmldocs/part1-3.phtml
http://www.rtr.com/fp2002disc/
http://www.joshie.com/projects/apache-frontpage/
http://www.freebsddiary.org/apache13-php3-fp-modssl.php
http://www.microsoft.com/technet/treeview/default.asp?url=/TechNet/prodtechnol/sharepnt/proddocs/admindoc/owsd02.asp
http://home.edo.uni-dortmund.de/~chripo/

Thank you very much for any help.

Mike.



_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message