httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Phelps <onelinux...@netscape.net>
Subject Re: cgi-bin newbie
Date Sat, 16 Mar 2002 08:41:24 GMT
Make aure the folder cgi-bin has the correct  permission. Are you 
running the script from the default web? Or from a virtual web?

Pietro Cagnoni wrote:

>>sorry all- a newbie question ;)
>>
>>installed the following:
>>
>>RH linux 7.2
>>apache 1.3
>>
>>trying to get cgi-bin files to execute, but get "internal server error".
>>pretty sure its a permissions or owner issue on the directory or file.
>>already tried to chown directory and files to apache and chmod
>>directory/files to 755 -  but no luck.  can't figure out what else i'm
>>missing.
>>
>>can anyone lead me in the right direction?
>>
>>thanks!
>>
>>rick
>>
>
>the right direction is the error log. i never used redhat, but i suppose
>it's in /var/log, or maybe /var/log/apache. the file name is usually
>error_log or error.log. grep your httpd.conf for the ErrorLog directive.
>
>everything the cgi program writes on stderr goes there.
>
>hope this helps.
>
>pietro.
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>


Mime
View raw message