httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandra Hernandez <san...@fib.upc.es>
Subject Re: apache with ssl causes segmentation fault
Date Tue, 05 Mar 2002 12:44:16 GMT
Hello,

Finally I found where was the problem... I suppose that the solution can
be useful to somebody, so I will explain as better as I can what was
happened.

I installed apache 1.3.23 with mod_ssl-2.8.6-1.3.23 in a Red Hat 7.2. 
User's authentication method in this system is performed using local
files and a ldap server, so /etc/nsswitch.conf is configured like that:

passwd:     files ldap
shadow:     files ldap
group:      files 

The problem was that nsswith.conf was configured with:
group:      files ldap

And group information isn't in ldap server.

The Segmentation fault problem was only in the case I try to start
apache like this: #./apachectl startssl 
and not with:  #./apachectl start

Goodbye,

Sandra

Sandra Hernandez wrote:
> 
> Hi all,
> 
> We have installed apache 1.3.23 with mod_ssl-2.8.6-1.3.23, and if
> mod_ssl is installed like a module (libssl.so) apache causes a
> segmentation fault.
> There is a little part of the log:
> 
> [Sun Feb 24 19:05:49 2002] [notice] child pid 27350 exit signal
> Segmentation fault (11)
> [Sun Feb 24 19:05:49 2002] [notice] child pid 27349 exit signal
> Segmentation fault (11)
> [Sun Feb 24 19:05:49 2002] [notice] child pid 27348 exit signal
> Segmentation fault (11)
> [Sun Feb 24 19:05:49 2002] [notice] child pid 27342 exit signal
> Segmentation fault (11)
> 
> If mod_ssl is not installed like a module, apache runs properly, but
> then I can't add more modules (php,pam,...).
> 
> I use gdb to see where is the problem:
> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 1024 (LWP 31019)]
> 0x4036de27 in SHA1_Update () from
> /home/soft/apache_1.3.23/libexec/libssl.so
> (gdb) quit
> 
> It seems that libssl has problems with SHA1 (openssl library), but I
> don't know what I can do, because I had reinstalled openssl and mm
> several times.
> 
> Openssl version is 0.9.6c
> Mm version is 1.1.3
> 
> Thanks for all responses,
> 
> Sandra
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

-- 
/"\
\ /  ASCII Ribbon Campaign
 x   Say NO to HTML in email and news
/ \

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message