httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Horner, Jonathan J. (JH8) " <...@y12.doe.gov>
Subject mod_proxy related issue, possibly
Date Thu, 14 Mar 2002 21:26:16 GMT
I have an issue, I think, with mod_proxy.

We have a Stronghold server (Stronghold/3.0 Apache/1.3.12 C2NetEU/3012
(Unix) PHP/3.0.16 mod_ssl/2.6.4 OpenSSL/0.9.5a mod_perl/1.22 configured)
which is set up to be a proxy server to a search engine.  In order to
provide more security, we have the stronghold server listening on 443, and
providing authentication to the search engine.  When we request from the
proxy server, if the page isn't too large (don't know the apparent
threshold), everything shows up fine.  If the page is larger (possibly >
9000bytes), the page gets jumbled and the end is displayed prior to the
status code and Content-type/Content-length return headers.  Then the
beginning of the page appears under the rest:

...
</td></tr></table><p>
</body>
</html>

HTTP/1.0 200 OK
Server: Ultraseek/3.1 Python/1.5.1
Date: Thu, 14 Mar 2002 21:09:17 GMT
Content-type: text/html
Content-length: 10544

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html>
<head>
...

When this specific page is requested via the search engine directly
everything appears as expected.

Any ideas?


Thanks,

Jon Horner
WebPool
jh8@y12.doe.gov
Office:  (865) 425-5178
Pager:  (865) 417-5012


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message