httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Turcu" <Adri...@InterXion.com>
Subject Apache 1.3.22 and SunOS2.6
Date Tue, 12 Feb 2002 14:26:36 GMT

Hello all,

I have a strange problem with Apache on SunOS2.6
I downloaded the archive of Apache 1.3.22 and I tried to installed under my SunOS box using
the following directives:

#!/bin/sh

SSL_BASE="../openssl-0.9.6b"
EAPI_MM="../mm-1.1.3" 
export SSL_BASE EAPI_MM

./configure \
        --prefix=/export/home/adriant/temp/apache \
        --enable-rule=SHARED_CORE \
        --enable-shared=max \
        --enable-module=ssl \
        --enable-module=so \
        --enable-module=auth_anon \
        --enable-module=cern_meta \
        --enable-module=digest \
        --enable-module=expires \
        --enable-module=headers \
        --enable-module=info \
        --enable-module=log_agent \
        --enable-module=log_referer \
        --enable-module=mime_magic \
        --enable-module=mmap_static \
        --enable-module=proxy \
        --enable-module=rewrite \
        --enable-module=unique_id \
        --enable-module=usertrack \
        --enable-module=vhost_alias \
        --server-uid=nobody --server-gid=nobody 


I have OpenSSL, MM, ModSSL configured and compiled for this.

The compilation works perfect, but when I try to start the httpd daemon with "apachectl start"
I got this strange message:

Segmentation Fault
Apachectl start: httpd server could not be started


I'm using gcc/2.95.3 for sparc-sun-solaris2.6, make/3.79.1, binutils/2.11.2, bison/1.28, flex/2.54a,
m4/1.4

I wonder what I miss on this.
I did Apache installations under Linux with absolutely no problem, but this SunOS2.6 on UltraSPARC
is killing me.

TIA,
Adi



Mime
View raw message