httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafael Corvalan" <Rafael.Corva...@linkvest.com>
Subject Conflict between a custom require directive and mod_dir
Date Thu, 28 Feb 2002 17:49:21 GMT
Hello,

I developped an authentication/autorization module in perl that works
fine unless used with mod_dir.
In fact, my module accepts custom require directives such as:

require ldapquery ldap://ldap......

This module worked fine until today, when I tried to access a default
page such as: http://www.mysite.com/ using mod_dir.
When the page is requested, mod_dir tries to serve index.html, then
index,php etc....

In the directory there is a file index.html that is correctly sent if I
dont have a require directive, or if I have a "require valid-user"
directive.
But with the custom directive I get the error:

[Thu Feb 28 18:21:38 2002] [error] [client 10.2.1.19] access to
/ccsr/fwlogs/index.html failed, reason: unknown require
directive:"ldapquery ldap://<cutted>"
[Thu Feb 28 18:21:38 2002] [error] [client 10.2.1.19] access to
/ccsr/fwlogs/index.html failed, reason: user rco not allowed access


If I put "require valid-user" it works.
If I let "require ldapquery..." but I access directly
/ccsr/fwlogs/index.html, it works.

Does someone have an idea?

Thanks and regards
Rafael

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message