httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject Re: ExecCGI turned off?
Date Wed, 13 Feb 2002 08:58:42 GMT
Cliff wrote:
> 
> Hi folks,
> 
> Why can't I run a cgi script?  After a fresh RPM install with a new
> httpd.conf file... the only thing I changed in the httpd.conf file was
> to uncomment # AddHandles cgi-script .cgi, and change the document root
> to reflect where the htdocs are kept.
> 
> When I try to access a cgi script in a browser, the return is
> "Forbidden, You don't have permission to access /env.cgi on this
> server".  I have tried setting permissions to 777 for files and
> directory, but doesn't have any effect.
> 
> The error_log reads, "Options ExecCGI is off in this directory:
> /var/www/htdocs/env.cgi".
> 
> Why is it looking in the htdocs directory?

Because, you told it to. Did you really type "/env.cgi" into the
browser? If so, it will look for "DocumentRoot"/env.cgi.

Try typing /cgi-bin/env.cgi and check your path in ScriptAlias

Rgds,

Owen Boyle

> 
> The .cgi file is in the cgi-bin and I believe ExecCGI is turned on by
> default with:
> 
> <Directory "/var/www/cgi-bin">
> AllowOverride None
> Options ExecCGI
> Order allow,deny
> Allow from all
> </Directory>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message