httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject Re: Virtual Hosts and SSI's
Date Wed, 13 Feb 2002 07:52:27 GMT
Tom Ray wrote:
> 
> I'm fairly new with setting up an apache web server. I have a Red Hat
> 7.1 machine here at my house, and I installed Apache 1.3.3 on it. I went
> through the httpd.conf file at set my virtual hosting up with IP's on
> the localnetwork so I can test some sites that way. 198.162.x.x, etc....
> 
> What's happening now is none of my SSI's or any CSS's are working. I've
> made sure the ServerParse line for .shtml is uncommented in the
> httpd.conf, but it's still not working.
> 
> IS there something I'm missing to make Server Side Includes and the
> Cascading Style Sheets work?

Don't know about CSS - it's up to the browser to handle the style
definitions. Nothing to do with apache. Are the definitions in a
separate file? Is the browser succeeding to download it? (check the
access_log).

As for SSI, you need to allow includes and add a handler, e.g.

  # Allow Server-Side Includes
  <Directory /path/to/your/shtml>
    AddHandler  server-parsed shtml
    Options     +Includes
  </Directory>

Rgds,

Owen Boyle.

PS - Apache 1.3.3? That went out with the ark - 1.3.23 is now available,
you know!

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message