httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff <a...@cruzio.com>
Subject ExecCGI turned off?
Date Wed, 13 Feb 2002 02:35:10 GMT
Hi folks,

Why can't I run a cgi script?  After a fresh RPM install with a new
httpd.conf file... the only thing I changed in the httpd.conf file was
to uncomment # AddHandles cgi-script .cgi, and change the document root
to reflect where the htdocs are kept. 

When I try to access a cgi script in a browser, the return is
"Forbidden, You don't have permission to access /env.cgi on this
server".  I have tried setting permissions to 777 for files and
directory, but doesn't have any effect. 

The error_log reads, "Options ExecCGI is off in this directory:
/var/www/htdocs/env.cgi".

Why is it looking in the htdocs directory?

The .cgi file is in the cgi-bin and I believe ExecCGI is turned on by
default with:
 
<Directory "/var/www/cgi-bin">
AllowOverride None
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

Anyone know what I'm overlooking?  Any help is much appreciated.

Thanks very much,
Cliff

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message