httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhodes, Phillip C." <Phillip.Rho...@alcoa.com>
Subject mod_ext_filter config question
Date Tue, 26 Feb 2002 15:15:52 GMT
I defined a filter for a location, but I only want the filter to run for
text/html stuff, not images.  If I specify intype of "text/html", my filter
is not activated.  It is activated if I do not specify an intype.

The problem is that the Content Type that I want filtered is "text/html;
charset=8859_1"

I think the extra stuff(;charset=...) is causing the filter not to be
triggered.  I tried the following, none of which work:

ExtFilterDefine test-filter mode=output intype=text/html;charset=8859_1
outtype=text/html cmd="/ale/usr01/h3/rhodepc/sillyFilter.pl"

ExtFilterDefine test-filter mode=output intype=text/html outtype=text/html
cmd="/ale/usr01/h3/rhodepc/sillyFilter.pl"


This works, but as I said, it will run for everything (including images)
ExtFilterDefine test-filter mode=output
cmd="/ale/usr01/h3/rhodepc/sillyFilter.pl"

Thanks..


quick overview...
I am using mod_proxy to proxy a web application that has fully qualified
href's in it.  I will pass it to a perl filter and do a regex on it to rip
and replace the url's in the content before sending it to the client.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message