httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <mirones2...@iol.pt>
Subject Reverse Proxy with backend web servers
Date Wed, 13 Feb 2002 12:07:37 GMT
Hello All,

I have a Reverse Proxy running on  Linux with apache 2.08 and 2 
backend web servers running microsoft IIS. The current configuration 
of reverse proxy it's similar to this :
...
<VirtualHost *>
servername www.host1.com
proxypass / http://10.1.1.10/
proxypassreverse / http://10.1.1.10/
</VirtualHost>
<Virtualhost *>
servername www.host2.com
proxypass / http://10.1.1.11/
proxypassreverse / http://10.1.1.11/
</Virtualhost>
...

Description of the problem:
If I access directly to Web Servers, everything runs fine.
if i try to access the web servers trought the reverse 
proxy,the execution of cgi-scripts won't run, i.e.,
       it's read normal html pages and sub html pages but 
when i have cgi scripts to run, (for example submit or         
search buttons) scripts that are supose to return me values, 
they wont run returnning me a error that I'm         
supossed to run the scripts localy not remotly.

Best Regards,

Nuno Cansado


__________
http://www.IOL.pt
Todo o mundo passa por aqui!



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message