httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sterling Anderson" <sterl...@sterlinganderson.net>
Subject RE: Apache behind a router?
Date Wed, 27 Feb 2002 20:04:29 GMT
Hmm, not exactly sure what you mean. I have my routing set up with
Forwarding. If I use "NameVirtualHost [RouterIP]" it does nothing new.
If I use "NameVirtualHost [INTERNALIP]" it says this:

[Wed Feb 27 13:56:38 2002] [warn] VirtualHost WEBSITE1.NET:80 overlaps
with VirtualHost WEBSITE2.NET:80, the first has precedence, perhaps you
need a NameVirtualHost directive
[Wed Feb 27 13:56:39 2002] [warn] NameVirtualHost 192.168.1.103:80 has
no VirtualHosts

The first warning is repeated 3 more times, once for each of the other
domains. My virtual host config looks like this:


NameVirtualHost 192.168.1.103

<VirtualHost WEBSITE1.net>
ServerName WEBSITE1.net
ServerAlias www.WEBSITE1.net
DocumentRoot /var/www/WEBSITE1
</VirtualHost>

The "<VirtualHost>...</VirtualHost> is repeated for the other 3 domains.



-----Original Message-----
From: Darrel Austin [mailto:daustin@visi.com] 
Sent: Wednesday, February 27, 2002 1:26 PM
To: users@httpd.apache.org
Subject: Re: Apache behind a router?


You'll need to set up your virtual hosts to accommodate the new internal
IP addresses your router is serving the machines internally (unless you
still have your server set up with a static IP and the router is just
letting it pass through).

-Darrel

on 2/27/02 1:19 PM, Sterling Anderson at sterling@sterlinganderson.net
wrote:

> Not sure if this is an Apache question or a router question. My Linux 
> server is running Debian and I installed Apache using Apt. I have 4 
> domains going to my machine and I set them up using Name-based Virtual

> Hosts. Everything worked fine until I put the server behind my router.

> The router is a linksys cheapo model. I have all traffic for port 80 
> going to the Apache server but it has stopped forwarding correctly. 
> Does anyone know of any resources for changing my apache config or 
> updating my routing tables?
> 
> Thanks.
> 
> _________________________
> Sterling Anderson
> 
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server 
> Project. See <URL:http://httpd.apache.org/userslist.html> for more 
> info. To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project. See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message