httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject RE: Configuring Apache
Date Wed, 30 Jan 2002 16:00:51 GMT

> From: Vasile.Curelea@cgi.ca [mailto:Vasile.Curelea@cgi.ca]
>
> I configured Apache 1.3.22 on a SunSolaris sparc 5.6 with the following
> options:
>
> # ./configure -- prefix=/usr/local/apache \
> # -- enable-module=most \
> # -- enable-shared=max

This means "use dynamic modules rather than static modules".

> # make
> # make install
>
> and when I do
>
> # ./httpd -l
> Compiled-in modules:
>   http_core.c
>   mod_so.c
> suexec: disabled; invalid wrapper /usr/local/apache/bin/suexec
> #
>

httpd -l lists only static modules.

> Only 2 modules shows as being added, I was expecting most of them to be
> displayed!
> The module that I'm interested in is mod_webapp. Any info on how to add
> that module would
> be appreciated.
> vasile

Modules that are included in the modules/ directory and referenced by
LoadModule statements in httpd.conf are not listed in httpd -l but are still
available.  mod_webapp is not included with the default apache distribution.
You will need to head over to http://jakarta.apache.org/ to get that.

Joshua.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message