httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject RE: Internal Error
Date Tue, 15 Jan 2002 18:42:11 GMT

> From: Sabherwal, Balvinder (MBS)
> [mailto:Balvinder.Sabherwal@mortgagefamily.com]

>
> > [Tue Jan 15 10:04:20 2002] [error] [client 10.90.74.122] couldn't spawn
> > child process: c:/program files/apache group/apache/cgi-bin/testapi.cgi

This error means "apache tried to start the cgi, but was unable to execute
it for some reason".  It is very common on win32, and unfortuantely somewhat
vague.  It can be caused by any number of problems.

Perhaps most commonly, the bang-path on the first line of your script needs
to point to an executable interpreter.

> #!c:/perl/bin/perl.exe

Is perl actually located there?  Are you sure that there are no extraneous
control characters on that line that could be preventing apache from finding
the perl interpreter?

>
> httpd.conf file also has the settings specified for the perl.exe as well
>

What does that mean?  What settings does httpd.conf have for perl.exe?

Unfortunately, the win32 apache experts don't seem to participate in this
list.  They can most often be found at
news:comp.infosystems.www.servers.ms-windows

Joshua.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message