httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject Re: Bind Address Problem
Date Wed, 30 Jan 2002 08:01:46 GMT
Peter Robinson wrote:
> 
> Hi All,
> 
> I have an apache 1.3.20 server that I'm having some problems with it binding
> to a particular address.
> 
> OK so here's a rough outline of the system.
> 
> Rehat 6.2 (SMP machine) running apache 1.3.20 with mod_ssl 1.8.4
> We have one network card with three IP addresses bound to eth0 eth0:0 and
> eth0:1. We only want apache to bind to the IP address running on the eth0
> interface so in the config file I specify this with the config line
> 
> BindAddress 1.2.3.4
> 
> But it doesn't just bind to that IP address it binds to all the IP
> addresses -> the three interfaces and lookback and everything else. ie if I
> do a netstat -ap command it returns

If you have multiple IP addresses and VHs, I usually defeat all defaults
and specify bindings explicitly using the Listen directive (I never use
Bind or BindAddress). You can then do things like:

	Listen 1.2.3.4:80
	<VirtualHost 1.2.3.4:80>
	..
	</VirtualHost>

	Listen 1.2.3.4:8000
	<VirtualHost 1.2.3.4:8000>
	..
	</VirtualHost>

and be sure that only specified IP/ports will be listened to.

Rgds,

Owen Boyle.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message