httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Owen Boyle <...@bourse.ch>
Subject apache-1.3.22 conflict with mod_perl-1.25?
Date Wed, 23 Jan 2002 17:03:40 GMT
Greetings,

I have just spent most of the day trying to compile apache_1.3.22 with
mod_perl-1.25. No matter how I tweaked the options and environment, I
continually ended up with a binary which failed with:

	Apache.pm failed to load!.

This error was coming from a line in
mod_perl-1.25/src/modules/perl/mod_perl.c, namely:

    if(!(version = perl_get_sv("Apache::VERSION", FALSE)))
        croak("Apache.pm failed to load!"); /*should never happen*/

I was not exactly encouraged by the "should never happen" comment and I
couldn't be bothered trying to figure out what perl_get_sv() was
supposed to do so I ended up checking the mod_perl site and found that
the latest version is actually mod_perl-1.26. So I downloaded that,
compiled and it worked first time.

My question is: Has anyone else had problems with this mix of apache and
mod_perl? While we're at it: Does anyone have any ideas what the problem
actually was?

Rgds,

Owen Boyle.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message