httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Hansen" <apache-l...@ixokai.net>
Subject Apache 2.0.28 on WinXP as a service?
Date Sun, 27 Jan 2002 11:04:45 GMT
Hello,
    I'm attempting to get Apache 2.0.28 up and running on WinXP Pro, and am
having a problem or two. I built the sources and installed them as the
instructions indicated, and then (has administrator), ran "apache -k
install" without any problems.
    Success didn't continue, however. "apache -k start" produced the
following output:

Starting the Apache2 service
[Sun Jan 27 02:58:52 2002] [crit] (23497)Overlapped I/O operation is in
progress
.  : Apache2: Failed to start the service process.

    Strangely, however, if I run "apache" by itself from the command line,
the server starts and operates fine.... except, the following message is
entered into the error log for each connection received:

[Sun Jan 27 02:47:32 2002] [error] (32557)Socket is not connected:
setsockopt(SO
_UPDATE_ACCEPT_CONTEXT) failed.

    I do not know if these are related, since dispite the errors in
error.log, everything appears to operate fine when not running as a
service-- i'm simply noting it for completeness. (I also notice that there
are about three bug reports in the database about the
SO_UPDATE_ACCEPT_CONTEXT thing, btu did not see any which looked like
whatever the problem is that i'm having)

    Anyone have any ideas? I'm assuming I simply did not set something right
in httpd.conf :)

Thanks in advance.

--Stephen



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message