httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Gabriel Duquesnoy" <jean-gabr...@duquesnoy.de>
Subject RE: Can't connect to apache in the intranet
Date Wed, 12 Dec 2001 15:32:48 GMT
Can't connect to apache in the intranetHave looked at the error and access
logs of your Apache server? Try to connect to your linux machine using a
telnet to check that the TCP/IP communication is working fine. Ping just
tells you that the machine is there, but it does not proof that the TCP/IP
communication is working fine.
Testing locally on the Linux machine just tells you that Apche is working
fine, but nothing about the connectivity, as it is using a loopback and does
not even access the
Ethernet board.

Regards,

Jean-Gabriel
  -----Original Message-----
  From: Finotto, Fabio [eng] ITM [mailto:ffinotto@moog.it]
  Sent: Wednesday, December 12, 2001 4:29 PM
  To: 'users@httpd.apache.org'
  Subject: Can't connect to apache in the intranet


  Dear all,
  this is my first e-mail in a mailing list, so I hope I won't get a RTFM or
a STFW. Actually I tried to solve the problem by myself but I couldn't. I
don't know personally anyone that can help me, so that's why I'm here.

  The scenario: Windows equipped PCs connected on the ethernet of my
company. A firewall to protect the net.
  My goal: to install a Linux apache web server for the company intranet.
  The problem: I installed apache 1.3.22 from the source code, I made some
tries from the same PC using Netscape with the URL http://localhost/ or
http://localhost/test.php (test.php is my test program) or
http://10.99.2.33/test.php and everythig works fine. My ethernet board i
correctly configured with address 10.99.2.3, infact if I ping this address
from any of the Win stations of my intranet I get a correct reply. At this
point I thought everything was ready to work, but if I try, using Internet
Explorer, to connect to my Apache Server, I can't get anything but a blank
page. I tried to connect using the URL http://10.99.2.33 or
http://10.99.2.33/test.php. Then I tried to disconnect my PC and make a net
with only two PCs, the one with the Apache server and a Windows98 laptop,
but I had the same result. I tried then to inspect the http.conf file, but
on the base of the few things that I know, It seems to me to be OK. I tried
to add a Listen line specifying my IP address and the port 80, but I had no
good results.

  Probably I'm ignoring some fundamental aspects. Can anyone enlight my
narrow mind?

  Thank you very much!
  Fabio


Mime
View raw message