httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian P. Trotter" <btrot...@pobox.com>
Subject No password box using .htaccess
Date Mon, 31 Dec 2001 22:58:47 GMT
Running Apache 1.3.19 on OpenBSD 2.9

I have placed a .htaccess file in a private directory on my web
server. It is configured according to several tutorials I found. I
also configured the httpd.conf file and set it to AllowOverride All.
I created the .htpasswd file with the accounts I wanted to have
access. I then restarted the server.

After doing all this, when I try to go to the directory I restricted,
I only get the 403 Forbidden webpage come up. It never gives me a
password prompt to authenticate myself.

Does anyone have any suggestions? I am getting so flustered with this.
I have also tried specifying a group in the .htacces file and creating
a .htgroup.
If I remove the .htaccess file, or change the AllowOverride All to
AllowOverride None, it gives me access. So it is somewhat working.

Here is a copy of .htaccess:

AuthUserFile /usr/local/.htpasswd
AuthName "Secure_Login"
AuthType Basic
require user jsmith jdoe

Thank you for your help...
Brian T.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message