httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From WillyB <wil...@maniawaste.net>
Subject Make Error
Date Tue, 18 Dec 2001 15:48:38 GMT
Hello,

I am new to this list so I hope this is the correct place for my question.

I am getting an error during the final make of apache.

Here is what I am working with...

linux-2.2.16 (RedHat)

apache_1.3.22
mod_ssl-2.8.5-1.3.22
php-4.0.6
mod_perl-1.26
imap-2000c-1.6.1
perl-5.6.1

Imap and perl work fine at the moment btw.

Applyed mod-ssl to Apache source tree - worked
Pre-configured Apache for PHP4's configure step - worked

Configured PHP4 and apply it to the Apache source tree - worked
make and make installed php - worked

Applyed mod_perl to Apache source tree and built and
installed the Perl-side of mod_perl - worked
(make and make installed) - worked

Then I built apache like this:

SSL_BASE=SYSTEM \
EAPI_MM=SYSTEM \
CC="egcs" \
OPTIM="-O9 -funroll-loops -ffast-math -malign-double -mcpu=pentiumpro 
-march=pentiumpro -fomit-frame-pointer -fno-exceptions" \
CFLAGS="-DDYNAMIC_MODULE_LIMIT=0" \
./configure \
--prefix=/home/httpd \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib/apache \
--includedir=/usr/include/apache \
--sysconfdir=/etc/httpd/conf \
--localstatedir=/var \
--runtimedir=/var/run \
--logfiledir=/var/log/httpd \
--datadir=/home/httpd \
--mandir=/usr/man \
--add-module=src/modules/experimental/mod_mmap_static.c \
--add-module=src/modules/standard/mod_auth_db.c \
--enable-module=ssl \
--enable-rule=SSL_SDBM \
--disable-rule=SSL_COMPAT \
--activate-module=src/modules/php4/libphp4.a \
--enable-module=php4 \
--activate-module=src/modules/perl/libperl.a \
--enable-module=perl \
--disable-module=negotiation \
--disable-module=asis \
--disable-module=imap \
--disable-module=env \
--disable-module=actions


After this I do the make and this is where the error comes.
Here is the error:

DynaLoader/DynaLoader.a -L/usr/local/lib/perl5/5.6.1/i686-linux/CORE -lperl 
-lnsl -ldl -lm -lc -lposix -lcrypt -lutil  -lmm
/usr/lib/libc-client.a(osdep.o): In function `auth_gssapi_valid':
/usr/src/bs/BUILD/imap-2000c/c-client/auth_gss.c:64: undefined reference to 
`gss_nt_service_name'
/usr/src/bs/BUILD/imap-2000c/c-client/auth_gss.c:64: undefined reference to 
`gss_import_name'

....... and more lines like that, all have to do with imap.

Ok.. I already know there is no /usr/src/bs   directory.. which is the problem.

My question is what to do about that!  Where do I get what is in that dir?
Am I just doing something wrong?

I apologize if my question is not appropriate for this list.

Thanks in advance for any hints or help :)

Willy B.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message