httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nazzaro, Mark (Mark)" <mnazz...@lucent.com>
Subject RE: Siteminder web agent problem
Date Thu, 06 Dec 2001 14:14:38 GMT
Nicolas, it is probably best if you edit the apachectl startup script. I
believe you can add this path in there. Hope this helps. Let me know if it
works. I had a similar problem with Siteminder and I edited the apachectl
script and it worked.

Mark Nazzaro
eAssociate
Lucent Technologies
Phone: (908) 559-6105


-----Original Message-----
From: ELOY,NICOLAS (HP-FtCollins,ex1) [mailto:nicolas_eloy@hp.com]
Sent: Wednesday, December 05, 2001 5:35 PM
To: 'users@httpd.apache.org'
Subject: Siteminder web agent problem


Hello all,

I am currently using a 1.3.19 Apache web server on HP-UX 11i and I wanted to
install the Siteminder web agent on it, which is simply a module that you
load dynamically by adding these lines into the httpd.conf file: 

LoadModule hpaCCso_module     /opt/siteminder/webagent/lib/mod_hpaCCso.sl
HPaCCLoadModule sm_module     /opt/siteminder/webagent/lib/mod_sm.sl

When I first tried to start the web server after saving the modifications to
httpd.conf I got these error messages:

/usr/lib/dld.sl: Unresolved symbol: U_get_unwind_entry (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_get_shLib_text_addr (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_resume_execution (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_update_state_vector (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_get_shLib_unw_tbl (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_get_previous_frame_x (code)  from
/usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: U_get_unwind_table (code)  from
/usr/lib/libCsup.2
Syntax error on line 257 of /home/psoft/webserv/conf/httpd.conf:
Cannot load /opt/siteminder/webagent/lib/mod_sm.sl into server: No such file
or directory
./apachectl start: httpd could not be started

I thought I should export the SHLIB_PATH variable to the path where the
shared library mod_sm.sl is, so I did it: export
SHLIB_PATH=$SHLIB_PATH:/opt/siteminder/webagent/lib

But I still had the same error messages.

By using "chatr httpd", I found out that httpd was not using SHLIB_PATH to
locate shared libraries, so I used the command "chatr +s enable httpd" to
enable it.
I also have checked that the line "PassEnv SHLIB_PATH" is present in
httpd.conf.
But I still have the same error messages.
Does anybody have any idea why it does not find this
/opt/siteminder/webagent/lib/mod_sm.sl library?

Thanks in advance,

Nicolas Eloy

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message