httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nazzaro, Mark (Mark)" <mnazz...@lucent.com>
Subject RE: Help with Name Based Virtual Hosting needed please. Thanks i n advance!!
Date Wed, 05 Dec 2001 20:18:29 GMT
Try taking out the serverName parameter towards the top of the httpd.conf.
Can you paste your entire httpd.conf here?
 

Mark Nazzaro 
eAssociate 
Lucent Technologies 
Phone: (908) 559-6105 

-----Original Message-----
From: List Account [mailto:lists@wjcc.org]
Sent: Wednesday, December 05, 2001 3:15 PM
To: users@httpd.apache.org
Subject: Help with Name Based Virtual Hosting needed please. Thanks in
advance!!


Hi,

I have RH 7.2 and Apache 1.3 (Newest) setup, and I am trying to set it up to
host multiple top level domains.

My server has 1 IP that is set for the main domain I am hosting(main
domain) This works fine.

I have another tl domains setup in other DNS servers that also resolve
to my IP.

I have the httpd.conf virtual hosts setup like this(the domain names
have been changed to protect the innocent, and the IP represented by
the xx.xx.xx.xx are the same in both directives)
-----------------------------Cut & Paste-----------------------

<VirtualHost xx.xx.xx.xx>
    ServerAdmin  <mailto:will@wherever.com> will@wherever.com
    DocumentRoot /var/www/html
    ServerName  <http://www.wherever.com> www.wherever.com
</VirtualHost>

<VirtualHost xx.xx.xx.xx>
    ServerAdmin  <mailto:will@wherever.com> will@wherever.com
    DocumentRoot /var/www/html/anotherdomain.net
    ServerName  <http://www.anotherdomain.net> www.anotherdomain.net
DirectoryIndex index.htm
</VirtualHost>

------------------------------------------------------------------

When I go to  <http://www.wherever.com> www.wherever.com (the main domain)
the page loads fine
and the whole site works flawlessly.

When I got to  <http://www.anotherdomain.net> www.anotherdomain.net I get
the  <http://www.wherever.com> www.wherever.com main
page, and none of the links to the rest of the site work.

But if I go to  <http://www.anotherdomain.net/index.htm>
www.anotherdomain.net/index.htm I get the right page
for the second domain (anotherdomain.net)  and the whole site works
fine.  How do I get it so it defaults to the index.htm file in this
secondary domain, instead of me having to specify it in the URL???

I am SOOO close, but I cannot figure it out!  Please help!!!

TIA!!!!!!

Will



Mime
View raw message