httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Suhre / Antero web technologies <st...@Antero.com>
Subject httpd processes keep growing, and growing.....
Date Mon, 10 Dec 2001 22:07:18 GMT


I've just installed apache 1.3.22 with mod_ssl 2.8.5. Apache seems to work
just fine when it's started, but after a day or 2 it will connect but then
hang and not deliver any content. A check of the server reveals over 150
httpd processes running. If I stop apache and restart it it will begin
working again, at least for a day or two. We're running bsdi 4.1 and have
had earlier versions of apache running on this machine for years. The
server is moderately busy, delivering 10-20 thousand pages a day. The log
files simply show 
"[Sat Dec  8 17:40:18 2001] [error] (57)Socket is not connected:
getsockname" continuously when apache is no longer working properly, no
other warnings or errors. The httpd.conf file seems to have all of the
limits set correctly:

MinSpareServers 5
MaxSpareServers 10
#
# 
StartServers 5
# 
#
MaxClients 150

Just wondering what else I need to do. It seems that there are processes
that should be closing, but are not. This is virtually the same setup we
had on the previous version of apache (1.3.12) on this same machine which
ran without problems. The problems seem to occur whether or not ssl is
enabled.

Thanks!





--
Steve Suhre
Antero web technologies
1.719.634.8161
steve@Antero.com
http://www.Antero.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message