httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Meyer <anme...@anup.de>
Subject Re: IPv6 mit dem Apache Webserver
Date Thu, 20 Oct 2011 17:02:43 GMT
Reindl Harald <h.reindl@thelounge.net> wrote:

> >>> Problem mit dem 403. http://www.elektromarke.de
> >>
> >> Kann von hier ( 141.84.151.28 / 2001:4ca0:4901:0:9037:30cf:65f1:3805 )
> >> aus problemlos auf http://www.elektromarke.de zugreifen.
> 
> Ich nicht, der Server ist schlichtweg falsch konfiguriert
> 141.84.151.28

Moment, das war die IP von Heinrich. Meine lautet 2a01:4f8:61:2122::2

> Für IP-Based Hosts brauchst du für jeden eine vollständige
> valide Konfiguration samt Dokument-Root weil wenn nur der
> DNS hinzeigt liefert der Indianer sonst die default-Seite
> und wenn der Ordner leer ist einen 403er

Ich habe doch eine vollständige Konfiguration des vhost gepostet.
Und der DNS antwortet richtig.

andreas@itx:~> host -aaaa www.elektromarke.de
Trying "www.elektromarke.de"                                                             
                                                                                    
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18902                    
                                                                                         
      
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 5, ADDITIONAL: 0                     
                                                                                    
                                                                                         
                                                                                    
;; QUESTION SECTION:
;www.elektromarke.de.           IN      ANY

;; ANSWER SECTION:
www.elektromarke.de.    4789    IN      AAAA    2a01:4f8:61:2122::2
www.elektromarke.de.    2583    IN      A       78.47.3.18

;; AUTHORITY SECTION:
de.                     168140  IN      NS      f.nic.de.
de.                     168140  IN      NS      z.nic.de.
de.                     168140  IN      NS      s.de.net.
de.                     168140  IN      NS      a.nic.de.
de.                     168140  IN      NS      l.de.net.

Komischerweise funktioniert ein ping.

andreas@itx:~> ping www.elektromarke.de
PING www.elektromarke.de (78.47.3.18) 56(84) bytes of data.
64 bytes from elektromarke.de (78.47.3.18): icmp_seq=1 ttl=57 time=20.2 ms

Andreas

> Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie
> bitte den Webmaster hierüber. Error 403
> 
> >> Oder verstehe ich was falsch?
> > 
> > Nein, nichts falsch. Wenn Du zugreifen kannst und ich nicht, dann
> > haben wir wahrscheinlich genau das Problem
> > dass z.B. mein Speedport
> > Router einfach kein IPv6 versteht; und der Apache funktionier wie er
> > soll. Ich komme offenbar hier nur mit IPv4 raus. Wie wäre jetzt
> > hilfreich, zu wissen, wie Du auf das IPv6 draufkommst, mit welcher
> > Hardware?
> 
> Nochmal: Das Problem ist das 99.5% der User da draussen schlicht und
> ergreifend keine ivp6-Adressen haben weil sie die meisten Provider
> gar nicht anbieten und Tunnel/Broker-Lösungen sind eher selten
> 


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message