httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Lüftenegger <mlu...@gmail.com>
Subject Re: Documentroot im Netzwerk
Date Wed, 06 Apr 2011 07:47:06 GMT
Wenn ich mir unter Verwaltung alle angelegten Benutzer ansehe(auch die
deaktivierten) ist keiner da, der für Apache in Frage kommen dürfte.
Nur Admin, Gast, Hilfeassistent, "meiner" und Support.

Ich habe inzwischen unter Win7 jedemm Benutzer Vollzugriff auf
betroffenen Ortner erteilt, ebenso in den Freigaben.

Ich werde jetzt mal Apache deinstallieren und neu installieren.

:michael

2011/4/6 Matthias Seidl <m.seidl@live.de>:
> Windows7 ist ja ein bisschen komisch was die Benutzerrechte angeht - ist eine Gäste
Leseberechtigung gesetzt? Während du den Browser benutzt bist du ja kein Benutzer.
>
> Michael Lüftenegger <mlueft@gmail.com> schrieb:
>
>
>
>> Hi Email!
>>
>> Das Laufwerksmapping läuft auf Benutzerebene. Daher habe ich den
>> Service so konfiguriert, dass er unter meinem Benutzer läuft. Wenn ich
>> den freigegebenen Ortner als Z mounte und in der Apachekonfiguration
>>
>> DocumentRoot "Z:"
>>
>> eintrage, startet der Service nicht. Fehler: "DocumentRoot must be a directory".
>>
>> p.s.: DocumentRoot "Z:\" - Führt zum selben Fehler.
>>
>>
>> 2011/4/6 Michael Lüftenegger <mlueft@gmail.com>:
>>> Hi!
>>>
>>> Bitte entschuldige, ich habe die Mail gestern nacht geschrieben und
>>> konnte sie nicht schicken, weil das IPad natürlich keine
>>> PlainTextmails versendet und da war ich kurz davor den Laptop mit dem
>>> großen Hammer zu konfigurieren.
>>>
>>> Also, der aktuelle Stand sieht wie folgt aus:
>>>
>>> Um den Laufwerksmappingkram zu umgehen konfiguriere ich über die IP-Adresse:
>>>
>>> DocumentRoot "\\192.168.123.1\www"
>>>
>>> So startet der service jedoch nicht und meldet einen Syntaxfehler in
>>> der Config. Ich dachte mit, dass ein Backslash ja eine Escapesequenz
>>> einleitet und so habe deshalb alle verdoppelt.
>>>
>>> DocumentRoot "\\\\192.168.123.1\\www"
>>>
>>> So startet der Service. Wenn ich nun über den Browser darauf
>>> zugreife(egal ob von XP oder 7) bekomme ich einen 403 "Sie haben nicht
>>> die erforderliche Berechtigung, um die Seite anzuzeigen." Das heißt
>>> für mich, dass der Benutzer, unter dem der Service läuft nicht auf die
>>> Hostmaschine zugreifen darf. Also habe ich den Service so
>>> konfiguriert, dass er unter dem Benutzerläuft mit dem ich selbst in XP
>>> arbeite, denn ich kann darauf zugreifen. Trotzdem bekomme ich den 403.
>>>
>>> Das ist der aktuelle Stand. Danke für eure Hilfe.
>>>
>>> lg,
>>>
>>> michael
>>>
>>>
>>> 2011/4/6 Stefan Schlichtinger <steve@happinger.de>:
>>>> Hi,
>>>>
>>>> etwas mehr Infos wären gut.
>>>> Was genau funktioniert nicht? Kommt eine Fehlermeldung beim Starten vom Apache?
Wenn ja, welche genau? Schonmal in die Logs geschaut?
>>>>
>>>> Gruß
>>>>
>>>> Am 06.04.2011 um 08:48 schrieb Michael Lüftenegger:
>>>>
>>>>> Hi Leute!
>>>>>
>>>>> Ich brauche eure Hilfe ich konfiguriere seit drei Tagen und ich
>>>>> bekomme den Apache nicht zu laufen; Bin am Ende und weiss nicht mehr
>>>>> weiter.
>>>>>
>>>>> Ich habe einen Laptop mit windows7. Auf diesem Gerät habe ich VMWare
>>>>> installiert und eine virtuelle Maschine mit XP Pro eingerichtet.
>>>>> In XP sind der Apache/PHP und Mysql installiert. Die beiden Maschinen
>>>>> sehen sich im Netzwerk und ich kann jeweils von einer auf die andere
>>>>> zugreifen. Solange unter XP documentroot ein lokales Verzeichniss ist,
>>>>> läuft auch der Apache sauber und ich kann dokumente über http
>>>>> aufrufen.
>>>>>
>>>>> In Win7 habe ich einen Ordner freigegeben, den ich unter XP auch sehe
>>>>> und lesen/schreiben kann. Ich möchte Apache so konfigurieren, dass er
>>>>> diesen Ordner als Documentroot verwendet.
>>>>>
>>>>> Ich habe folgendes ausprobiert:
>>>>>
>>>>> * Netzwerklaufwerke laufen in Windows unter dem Benutzer, also den
>>>>> shared folder als Z eingebunden. Apache läuft als service mit dem
>>>>> Benutzer für den Z gemappt wurde.
>>>>> * Das selbe wie oben nur ungemappt als "\\192.168.123.1\www"
>>>>> * Documentroot auf lokales Verzeichnis und einen Alias für /www/ auf
>>>>> "\\192.168.123.1\www" eingerichtet.
>>>>>
>>>>> Um ehrlich zu sein, ich weiss nicht mehr was ich alles ausprobiert
>>>>> habe. Ich habe auf beiden Maschinen die selben Benutzer mit den selben
>>>>> Passworten eingerichtet. Ich habe alle einstellungen für den Apache
>>>>> service ausprobiert. Es will mir einfach nicht gelingen.
>>>>>
>>>>> Die Grundidee dahinter ist die, dass ich nicht jedesmal, wenn ich
>>>>> meinen Laptop aufsetze, den ganzen Webserverkram neu machen muss.
>>>>> Den PHP-Quellcode möchte ich aber nicht in der VM haben.
>>>>>
>>>>> Wäre super, wenn jemand was weiss, ich bin momentan am Ende.
>>>>>
>>>>>
>>>>> --
>>>>> http://www.kineticarm.com - your place to play online games
>>>>> http://www.flashgameblog.at - My blog about flash game making
>>>>> http://www.lueftenegger.at
>>>>>
>>>>> --------------------------------------------------------------------------
>>>>>                Apache HTTP Server Mailing List "users-de"
>>>>>      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>>>>>           sonstige Anfragen an users-de-help@httpd.apache.org
>>>>> --------------------------------------------------------------------------
>>>>>
>>>>
>>>>
>>>> --------------------------------------------------------------------------
>>>>                Apache HTTP Server Mailing List "users-de"
>>>>      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>>>>           sonstige Anfragen an users-de-help@httpd.apache.org
>>>> --------------------------------------------------------------------------
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> http://www.kineticarm.com - your place to play online games
>>> http://www.flashgameblog.at - My blog about flash game making
>>> http://www.lueftenegger.at
>>>
>>
>>
>>
>> --
>> http://www.kineticarm.com - your place to play online games
>> http://www.flashgameblog.at - My blog about flash game making
>> http://www.lueftenegger.at
>>
>> --------------------------------------------------------------------------
>>                 Apache HTTP Server Mailing List "users-de"
>>       unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>>            sonstige Anfragen an users-de-help@httpd.apache.org
>> --------------------------------------------------------------------------
>>
>
> --------------------------------------------------------------------------
>                Apache HTTP Server Mailing List "users-de"
>      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>           sonstige Anfragen an users-de-help@httpd.apache.org
> --------------------------------------------------------------------------
>
>



-- 
http://www.kineticarm.com - your place to play online games
http://www.flashgameblog.at - My blog about flash game making
http://www.lueftenegger.at

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message