httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Sokoll <r.sok...@intershop.de>
Subject Require und mod_auth_ldap
Date Wed, 15 Sep 2010 12:20:25 GMT
Hallo,

vorweg: LDAP-Authentifizierung funktioniert. require user und require
valid-user arbeiten wie erwartet, wobei die Usernamen aus einem
ActiveDirectory kommen.
Was nicht funktioniert: require dn - da bekomme ich ein

access to /trac/test/ failed, reason: unknown require directive:"dn cn=xxx, cn=xxx, dc=xxx,
dc=xxx, dc=xxx"

Der entsprechend Abschnitt in der Konfiguration:

  <LocationMatch /trac/test>
     AuthType Basic
     AuthLDAPEnabled on
     AuthLDAPAuthoritative on
     AuthLDAPBindDN "xxx\\xxx"
     AuthLDAPBindPassword xxx
     AuthLDAPUrl ldap://x.x.x.x:389/DC=xxx,DC=xxx,DC=xxx?sAMAccountName
     AuthName "Access to Test"
     # AuthLDAPCompareDNOnServer off
     # AuthAuthoritative Off
     SetHandler mod_python
     PythonHandler trac.web.modpython_frontend
     PythonOption TracEnv /svn/trac/test
     PythonOption TracUriRoot /trac/test
     Require dn cn=xxx, cn=xxx, dc=xxx, dc=xxx, dc=xxx
  </LocationMatch>

Das entspricht dem Beispiel aus der Doku:
http://httpd.apache.org/docs/2.0/mod/mod_auth_ldap.html#reqdn
Mich macht ja die Fehlermeldung stutzig: "Unknown require directive" -
es scheint, als könne er mit "dn" nichts anfangen, ich kann statt "dn"
auch sonstwas schreiben - die Fehlermeldung bleibt dieselbe.
mod_auth_ldap ist natürlich geladen.
Hat jemand eine Idee?
Auch würde ich gerne wissen, wie ich Authentifizierung/Autorisierung
debuggen kann.

Rainer

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message