httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Thommen <frank.thom...@drosera.ch>
Subject Re: Probleme mit LDAP Authentifizierung nach Wechsel von Apache 1.3 auf 2.2
Date Fri, 05 Jun 2009 19:34:45 GMT
Rainer Sokoll wrote:
> Frank Thommen wrote:
> 
>> <Files *.pl>
>>   SSLRequireSSL
>>   AuthType basic
>>   AuthBasicProvider ldap
>>   AuthzUserAuthoritative On
>>   AuthName "My Auth"
>>   AuthLDAPURL ldap://ldapserver:389/cn=Users,dc=embl,dc=org?uid?
>>   # AuthLDAPStartTLS off
>>   require <SIEHE UNTEN>
>> </Files>
> 
> Sollte es nicht AuthzLDAPAuthoritative anstelle von
> AuthzUserAuthoritative sein?

Doch :-|, "AuthzUserAuthoritative" ist aus dem falschen Module 
(mod_authz_user).  Mit "AuthzLDAPAuthoritative Off" funktioniert die 
Authentifizierung, mit "AuthzLDAPAuthoritative On" nicht.

Das verstehe ich allerdings nicht: Ich will ja gerade mit 
mod_authnz_ldap authentifizieren??

Zudem steht im Manual: "When no LDAP-specific Require directives are 
used, authorization is allowed to fall back to other modules as if 
AuthzLDAPAuthoritative  was set to off." Da ich keine LDAP-spezifische 
require-Direktive habe, haette das Modul eigentlich auf 
"AuthzLDAPAuthoritative Off" zurueckfallen muessen...


Vielen Dank

    frank

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message