httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Behrens <behr...@takenet.de>
Subject Re: Extern eingebundene CSS funktionierten nicht
Date Wed, 24 Sep 2008 16:49:39 GMT
Michelle Konzack schrieb:
> Hallo Leute,
> 
> Seit gut sechs Wochen hühner ich hier mit apache2, php5  und  CSS  herum
> und bin am suchen weil es nicht funktioniert...
> 
> Hier eine Muster Seite:
>
> "apache2" sendet die Datei als "text/plain"  weshalb  sie  von  den  OSS
> "browsern" nicht als CSS erkannt wird...
> 
> Meineserachtens ist das ein Bug, nur von wem?  --  Brause oder Servierer?

Der Servierer.


> Und eine weitere Frage ist warum wollen sie die Browser  nicht  als  CSS
> haben wenn im <link> Tag bereits text/css angegeben ist?
> 
> Anm.:  Ich habe auf meinem Server nur ein einziges /htdocs/ Verzeichnis,
>        EINE einzige "index.php" und generiere ALLE VHosts dynamisch  aus
>        einer pgsql/mysql Datenbank.

Aber deine *.css kommt doch nicht aus der DB oder?. Weil wenn ja dann 
koennte der Fehler auch bei dir liegen da PHP per default text/html 
setzt. Du muesstest dann einen eigenen Content-Type Header mittels 
header() setzten.

Gruss
Joerg

-- 
TakeNet GmbH,                    Geschaeftsfuehrer Wolfgang Meier
97080 Wuerzburg                  Tel: +49 931 903-2243
Alfred-Nobel-Straße 20           Fax: +49 931 903-3025
HRB Wuerzburg 6940               http://www.takenet.de


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message