httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Rieder" <l.rie...@gmail.com>
Subject Re: Extern eingebundene CSS funktionierten nicht
Date Wed, 24 Sep 2008 16:29:30 GMT
Hallo Michelle,

kann gut sein, dass die MIME types für eine *.css Datei in der
Konfiguration nicht existieren.
Meine css Dateien werden, wenn ich sie direkt aufrufe als "text/css"
ausgeliefert.

In meiner /etc/apache2/apache2.conf Konfigurationsdatei (welche kaum
von der Standartkonfiguration abweicht) gibt es folgende Einträge (die
höchstwahrscheinlich dein Problem addressieren):

[...]
DefaultType text/plain

TypesConfig /etc/mime.types
[...]

Und wenn ich meine /etc/mime.types ansehe finde ich unter css folgenden Eintrag:

[...]
text/css                                        css
[...]

Ich würde vorschlagen du überprüfst diese Direktiven und siehst dir
diese Seite der Dokumentation an:
http://httpd.apache.org/docs/2.0/mod/mod_mime.html#typesconfig
Auch mod_mime sollte geladen sein.

Grüße,


Lukas

2008/9/21 Michelle Konzack <linux4michelle@tamay-dogan.net>:
> Hallo Leute,
>
> Seit gut sechs Wochen hühner ich hier mit apache2, php5  und  CSS  herum
> und bin am suchen weil es nicht funktioniert...
>
> Hier eine Muster Seite:
>
> ----[ STDIN ]-----------------------------------------------------------
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3c.org/TR/xhtml1/DTD/xhtml1-Transitional.dtd">
> <html>
> <head>
> <title>Hello World</title>
> <link rel="stylesheet" type="text/css" href="/css/meinstil.css">
> </head>
> <body>
> <div class="foo">Hallo users-de</div>
> </body>
> </html>
> ------------------------------------------------------------------------
>
> Nun, ich habe bereits /css/meinstil.css manuell aufgerufen und  sie  ist
> da, nur Mozilla, Firefox, Seamonkey und Iceape wollen sie nicht haben...
>
> Safari hingegen schon.
>
> Nun jetzt habe ich es herausgefunden (und meine seite funktioniert jetzt
> OHNE eine einzige Tabelle nur ohne CSS ist sie zerhackt):
>
> "apache2" sendet die Datei als "text/plain"  weshalb  sie  von  den  OSS
> "browsern" nicht als CSS erkannt wird...
>
> Meineserachtens ist das ein Bug, nur von wem?  --  Brause oder Servierer?
>
> Und eine weitere Frage ist warum wollen sie die Browser  nicht  als  CSS
> haben wenn im <link> Tag bereits text/css angegeben ist?
>
> Anm.:  Ich habe auf meinem Server nur ein einziges /htdocs/ Verzeichnis,
>       EINE einzige "index.php" und generiere ALLE VHosts dynamisch  aus
>       einer pgsql/mysql Datenbank.
>
> Thanks, Greetings and nice Day/Evening
>    Michelle Konzack
>    Systemadministrator
>    24V Electronic Engineer
>    Tamay Dogan Network
>    Debian GNU/Linux Consultant
>
> --
> Linux-User #280138 with the Linux Counter, http://counter.li.org/
> ##################### Debian GNU/Linux Consultant #####################
> Michelle Konzack   Apt. 917                  ICQ #328449886
> +49/177/9351947    50, rue de Soultz         MSN LinuxMichi
> +33/6/61925193     67100 Strasbourg/France   IRC #Debian (irc.icq.com)
>

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message